summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc534d1ca08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pscripts
+ pkgdesc = Noeljunior's pscripts: some handy scripts for users and sysadmins
+ pkgver = 0.1a
+ pkgrel = 1
+ url = https://github.com/Noeljunior/pscripts
+ arch = any
+ license = GPL
+ depends = git
+ source = pscripts::git+https://github.com/Noeljunior/pscripts
+ md5sums = SKIP
+
+pkgname = pscripts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02016a7d60b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Noeljnuior <liamgliamgmailcom>
+
+pkgname=pscripts
+pkgver=0.1a
+pkgrel=1
+pkgdesc="Noeljunior's pscripts: some handy scripts for users and sysadmins"
+arch=('any')
+url="https://github.com/Noeljunior/pscripts"
+license=('GPL')
+depends=(git)
+source=("$pkgname::git+https://github.com/Noeljunior/pscripts")
+md5sums=('SKIP')
+
+package() {
+ cd $srcdir/$pkgname
+
+ ./sysadmin/pscripts install "${pkgdir}/opt/$pkgname" "/opt/$pkgname" "${pkgdir}/etc/profile.d"
+}