summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
-rw-r--r--punes-0.108-Fixed-make-install.patch148
-rw-r--r--punes.install19
4 files changed, 30 insertions, 214 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86219cc68f8a..426a8a86cf1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,28 @@
pkgbase = punes
pkgdesc = Nintendo Entertaiment System emulator
- pkgver = 0.109
+ pkgver = 0.111
pkgrel = 1
url = https://github.com/punesemu/puNES
- install = punes.install
arch = i686
arch = x86_64
- license = GPL2
- makedepends = cmake
+ arch = aarch64
+ license = GPL-2.0-or-later
+ makedepends = cmake>=3.15
makedepends = glu
- makedepends = qt5-tools
+ makedepends = qt6-tools
depends = alsa-lib
- depends = desktop-file-utils
depends = ffmpeg
depends = hicolor-icon-theme
depends = nvidia-cg-toolkit
depends = libxrandr
- depends = qt5-base
- depends = qt5-svg
- provides = punes
- conflicts = punes-git
- options = !buildflags
- source = https://github.com/punesemu/puNES/archive/v0.109.tar.gz
- md5sums = 1dad44051a40790a03063d6ae6a4e5ed
+ depends = qt6-base
+ depends = qt6-svg
+ depends = gcc-libs
+ depends = glibc
+ depends = libglvnd
+ depends = libx11
+ depends = libudev.so
+ source = puNES-0.111.tar.gz::https://github.com/punesemu/puNES/archive/v0.111.tar.gz
+ sha512sums = 6388cdf2b303e217adfe43b1b3b1ef66a75b6adfdb0363b213c47fc129b5815f3e96814ee25a3637147dc184203cef0438930c280f0c6249085ecac1220b435c
pkgname = punes
diff --git a/PKGBUILD b/PKGBUILD
index ed92c470a7b0..16dbd9cc6ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,29 @@
-# Maintainer: Boris Timofeev <mashin87@gmail.com>
-# Maintainer: Fabio Cavallo (FHorse) <punes.development@gmail.com>
+# Maintainer: Lili1228 <aur at lili dot lgbt>
+# Contributor: Boris Timofeev <mashin87@gmail.com>
+# Contributor: Fabio Cavallo (FHorse) <punes.development@gmail.com>
pkgname=punes
-pkgver=0.109
+pkgver=0.111
pkgrel=1
-epoch=
pkgdesc="Nintendo Entertaiment System emulator"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/punesemu/puNES"
-license=('GPL2')
-groups=()
-depends=('alsa-lib' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'nvidia-cg-toolkit' 'libxrandr' 'qt5-base' 'qt5-svg')
-makedepends=('cmake' 'glu' 'qt5-tools')
-checkdepends=()
-optdepends=()
-provides=('punes')
-conflicts=('punes-git')
-replaces=()
-backup=()
-options=()
-install=$pkgname.install
-changelog=
-source=("https://github.com/punesemu/puNES/archive/v$pkgver.tar.gz")
-md5sums=('1dad44051a40790a03063d6ae6a4e5ed')
-noextract=()
+license=('GPL-2.0-or-later')
+depends=('alsa-lib' 'ffmpeg' 'hicolor-icon-theme' 'nvidia-cg-toolkit' 'libxrandr' 'qt6-base' 'qt6-svg' # explicit
+'gcc-libs' 'glibc' 'libglvnd' 'libx11' 'libudev.so') # implicit
+makedepends=('cmake>=3.15' 'glu' 'qt6-tools')
+source=("puNES-${pkgver}.tar.gz"::"https://github.com/punesemu/puNES/archive/v$pkgver.tar.gz")
+sha512sums=('6388cdf2b303e217adfe43b1b3b1ef66a75b6adfdb0363b213c47fc129b5815f3e96814ee25a3637147dc184203cef0438930c280f0c6249085ecac1220b435c')
-#breaks internal lib7zip
-options=('!buildflags')
-
-prepare() {
- cd "$srcdir/puNES-$pkgver"
- sed -e 's:^\tupdate-desktop-database.*$:\ttrue:' -i 'misc/Makefile.am'
-}
+# AUR 0.108-1 says lib7zip breaks with buildflags, but I can't find any proof, it builds and loads zips
+#options=('!buildflags')
build() {
- cd "$srcdir/puNES-$pkgver"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cmake -S"puNES-${pkgver}" -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_OPENGL_CG=on -DENABLE_QT6_LIBS=on -DDISABLE_PORTABLE_MODE=on
+ cmake --build build
}
package() {
- cd "$srcdir/puNES-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" cmake --build "${srcdir}/build" --target install
}
# vim:set ts=2 sw=2 et:
diff --git a/punes-0.108-Fixed-make-install.patch b/punes-0.108-Fixed-make-install.patch
deleted file mode 100644
index f6a595085ce8..000000000000
--- a/punes-0.108-Fixed-make-install.patch
+++ /dev/null
@@ -1,148 +0,0 @@
-From 902434f50398ebcda0786ade4b28a0496084810e Mon Sep 17 00:00:00 2001
-From: fhorse <punes.development@gmail.com>
-Date: Wed, 29 Dec 2021 19:12:29 +0100
-Subject: [PATCH] Fixed 'make install'.
-
----
- .../lib7zip-3.0.1wip-53abfeb-puNES.patch | 26 ++++++++++---------
- src/extra/lib7zip-53abfeb/CMakeLists.txt | 4 ++-
- src/extra/lib7zip-53abfeb/configure | 2 +-
- 3 files changed, 18 insertions(+), 14 deletions(-)
-
-diff --git a/src/extra/lib7zip-3.0.1wip-53abfeb-puNES.patch b/src/extra/lib7zip-3.0.1wip-53abfeb-puNES.patch
-index acd4c14b..6125f77f 100644
---- a/src/extra/lib7zip-3.0.1wip-53abfeb-puNES.patch
-+++ b/src/extra/lib7zip-3.0.1wip-53abfeb-puNES.patch
-@@ -1,9 +1,9 @@
- diff -upNr lib7zip-53abfeb.org/CMakeLists.txt lib7zip-53abfeb/CMakeLists.txt
- --- lib7zip-53abfeb.org/CMakeLists.txt 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/CMakeLists.txt 2021-09-19 15:12:38.078043955 +0200
-++++ lib7zip-53abfeb/CMakeLists.txt 2021-12-29 18:32:06.823795378 +0100
- @@ -1,4 +1,4 @@
- -CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
--+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.12)
-++CMAKE_MINIMUM_REQUIRED(VERSION 3.13)
-
- CMAKE_POLICY(
- SET CMP0048 NEW
-@@ -34,7 +34,7 @@ diff -upNr lib7zip-53abfeb.org/CMakeLists.txt lib7zip-53abfeb/CMakeLists.txt
- set(cxx_warnings "")
- set(no_undefined -Wl,-undefined,error)
- elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
--@@ -56,9 +59,12 @@ SET(CXX_STANDARD_REQUIRED OFF)
-+@@ -56,9 +59,14 @@ SET(CXX_STANDARD_REQUIRED OFF)
- SET(CXX_EXTENSION NO)
-
- if (NOT CONFIGURED_ONCE)
-@@ -48,9 +48,11 @@ diff -upNr lib7zip-53abfeb.org/CMakeLists.txt lib7zip-53abfeb/CMakeLists.txt
- ADD_SUBDIRECTORY(src)
- -ADD_SUBDIRECTORY(test)
- +#ADD_SUBDIRECTORY(test)
-++
-++install(FILES dummy DESTINATION bin OPTIONAL)
- diff -upNr lib7zip-53abfeb.org/configure lib7zip-53abfeb/configure
- --- lib7zip-53abfeb.org/configure 1970-01-01 01:00:00.000000000 +0100
--+++ lib7zip-53abfeb/configure 2021-09-19 15:06:57.196285060 +0200
-++++ lib7zip-53abfeb/configure 2021-12-29 18:31:54.871731271 +0100
- @@ -0,0 +1,355 @@
- +#!/bin/sh
- +
-@@ -406,7 +408,7 @@ diff -upNr lib7zip-53abfeb.org/configure lib7zip-53abfeb/configure
- +
- +#eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_BUILD_TYPE="${BUILD_TYPE}" -DCMAKE_INSTALL_PREFIX="${PREFIX}" -DCMAKE_INSTALL_LIBDIR="${LIBDIR}" ${CMAKE_ARGS}
- +#eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
--+eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
-++eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_INSTALL_PREFIX="${PREFIX}" -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
- diff -upNr lib7zip-53abfeb.org/.gitignore lib7zip-53abfeb/.gitignore
- --- lib7zip-53abfeb.org/.gitignore 2021-05-26 22:04:41.000000000 +0200
- +++ lib7zip-53abfeb/.gitignore 1970-01-01 01:00:00.000000000 +0100
-@@ -501,7 +503,7 @@ diff -upNr lib7zip-53abfeb.org/.hgignore lib7zip-53abfeb/.hgignore
- \ Manca newline alla fine del file
- diff -upNr lib7zip-53abfeb.org/src/7ZipFormatInfo.cpp lib7zip-53abfeb/src/7ZipFormatInfo.cpp
- --- lib7zip-53abfeb.org/src/7ZipFormatInfo.cpp 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/src/7ZipFormatInfo.cpp 2021-09-19 14:20:56.671905670 +0200
-++++ lib7zip-53abfeb/src/7ZipFormatInfo.cpp 2021-12-29 18:31:45.681682054 +0100
- @@ -4,6 +4,7 @@
- #endif
-
-@@ -512,7 +514,7 @@ diff -upNr lib7zip-53abfeb.org/src/7ZipFormatInfo.cpp lib7zip-53abfeb/src/7ZipFo
- #include "CPP/Common/MyCom.h"
- diff -upNr lib7zip-53abfeb.org/src/7ZipObjectPtrArray.cpp lib7zip-53abfeb/src/7ZipObjectPtrArray.cpp
- --- lib7zip-53abfeb.org/src/7ZipObjectPtrArray.cpp 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/src/7ZipObjectPtrArray.cpp 2021-09-19 14:21:44.925154586 +0200
-++++ lib7zip-53abfeb/src/7ZipObjectPtrArray.cpp 2021-12-29 18:31:45.681682054 +0100
- @@ -18,9 +18,9 @@ void C7ZipObjectPtrArray::clear()
- {
- if (m_bAutoRelease)
-@@ -527,7 +529,7 @@ diff -upNr lib7zip-53abfeb.org/src/7ZipObjectPtrArray.cpp lib7zip-53abfeb/src/7Z
-
- diff -upNr lib7zip-53abfeb.org/src/CMakeLists.txt lib7zip-53abfeb/src/CMakeLists.txt
- --- lib7zip-53abfeb.org/src/CMakeLists.txt 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/src/CMakeLists.txt 2021-09-19 14:22:53.391507308 +0200
-++++ lib7zip-53abfeb/src/CMakeLists.txt 2021-12-29 18:31:45.681682054 +0100
- @@ -7,6 +7,10 @@ SET(lib7zip_src
- 7ZipCodecInfo.h 7ZipFormatInfo.h 7zipLibrary.cpp OSFunctions_OS2.h
- )
-@@ -541,13 +543,13 @@ diff -upNr lib7zip-53abfeb.org/src/CMakeLists.txt lib7zip-53abfeb/src/CMakeLists
- )
- diff -upNr lib7zip-53abfeb.org/src/GUIDs.cpp lib7zip-53abfeb/src/GUIDs.cpp
- --- lib7zip-53abfeb.org/src/GUIDs.cpp 1970-01-01 01:00:00.000000000 +0100
--+++ lib7zip-53abfeb/src/GUIDs.cpp 2021-09-19 14:27:46.632076949 +0200
-++++ lib7zip-53abfeb/src/GUIDs.cpp 2021-12-29 18:31:45.681682054 +0100
- @@ -0,0 +1,2 @@
- +#include <initguid.h>
- +#include "GUIDs.h"
- diff -upNr lib7zip-53abfeb.org/src/GUIDs.h lib7zip-53abfeb/src/GUIDs.h
- --- lib7zip-53abfeb.org/src/GUIDs.h 1970-01-01 01:00:00.000000000 +0100
--+++ lib7zip-53abfeb/src/GUIDs.h 2021-09-19 14:27:46.632076949 +0200
-++++ lib7zip-53abfeb/src/GUIDs.h 2021-12-29 18:31:45.681682054 +0100
- @@ -0,0 +1,139 @@
- +// This file is based on the following file from the LZMA SDK (http://www.7-zip.org/sdk.html):
- +// ./CPP/7zip/Guid.txt
-@@ -690,7 +692,7 @@ diff -upNr lib7zip-53abfeb.org/src/GUIDs.h lib7zip-53abfeb/src/GUIDs.h
- +}
- diff -upNr lib7zip-53abfeb.org/src/HelperFuncs.cpp lib7zip-53abfeb/src/HelperFuncs.cpp
- --- lib7zip-53abfeb.org/src/HelperFuncs.cpp 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/src/HelperFuncs.cpp 2021-09-19 14:25:05.620215573 +0200
-++++ lib7zip-53abfeb/src/HelperFuncs.cpp 2021-12-29 18:31:45.681682054 +0100
- @@ -2,10 +2,12 @@
- #include "config.h"
- #endif
-@@ -706,7 +708,7 @@ diff -upNr lib7zip-53abfeb.org/src/HelperFuncs.cpp lib7zip-53abfeb/src/HelperFun
- #include "CPP/myWindows/StdAfx.h"
- diff -upNr lib7zip-53abfeb.org/src/OSFunctions_UnixLike.cpp lib7zip-53abfeb/src/OSFunctions_UnixLike.cpp
- --- lib7zip-53abfeb.org/src/OSFunctions_UnixLike.cpp 2021-05-26 22:04:41.000000000 +0200
--+++ lib7zip-53abfeb/src/OSFunctions_UnixLike.cpp 2021-09-19 14:26:54.366798374 +0200
-++++ lib7zip-53abfeb/src/OSFunctions_UnixLike.cpp 2021-12-29 18:31:45.681682054 +0100
- @@ -122,13 +122,13 @@ int myselect(const struct dirent * pDir
- {
- closedir( pTmpDir );
-diff --git a/src/extra/lib7zip-53abfeb/CMakeLists.txt b/src/extra/lib7zip-53abfeb/CMakeLists.txt
-index ad6422dd..ae546159 100644
---- a/src/extra/lib7zip-53abfeb/CMakeLists.txt
-+++ b/src/extra/lib7zip-53abfeb/CMakeLists.txt
-@@ -1,4 +1,4 @@
--CMAKE_MINIMUM_REQUIRED(VERSION 2.8.12)
-+CMAKE_MINIMUM_REQUIRED(VERSION 3.13)
-
- CMAKE_POLICY(
- SET CMP0048 NEW
-@@ -68,3 +68,5 @@ endif()
-
- ADD_SUBDIRECTORY(src)
- #ADD_SUBDIRECTORY(test)
-+
-+install(FILES dummy DESTINATION bin OPTIONAL)
-diff --git a/src/extra/lib7zip-53abfeb/configure b/src/extra/lib7zip-53abfeb/configure
-index 7499ffab..ca28ab14 100755
---- a/src/extra/lib7zip-53abfeb/configure
-+++ b/src/extra/lib7zip-53abfeb/configure
-@@ -352,4 +352,4 @@ fi
-
- #eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_BUILD_TYPE="${BUILD_TYPE}" -DCMAKE_INSTALL_PREFIX="${PREFIX}" -DCMAKE_INSTALL_LIBDIR="${LIBDIR}" ${CMAKE_ARGS}
- #eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
--eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
-+eval "${CMAKE_CMD}" "${TOP_SRCDIR}" -DCMAKE_INSTALL_PREFIX="${PREFIX}" -DBUILD_SHARED_LIB="OFF" -DP7ZIP_SOURCE_DIR="${P7ZIP_SOURCE_DIR}" ${CMAKE_ARGS}
---
-2.34.0
-
diff --git a/punes.install b/punes.install
deleted file mode 100644
index 716c0a0d4694..000000000000
--- a/punes.install
+++ /dev/null
@@ -1,19 +0,0 @@
-post_install() {
- update-mime-database /usr/share/mime 1> /dev/null
- update-desktop-database -q
- xdg-icon-resource forceupdate --theme hicolor
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- /bin/true
-}
-
-post_remove() {
- update-mime-database /usr/share/mime 1> /dev/null
- update-desktop-database -q
- xdg-icon-resource forceupdate --theme hicolor
-}