summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a698f2daba13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pve-spice-connect-git
+ pkgdesc = A bash script to easily connect to Proxmox PVE virtual machines via SPICE.
+ pkgver = r11.bebc2e4
+ pkgrel = 1
+ url = https://gitlab.com/pawlakm/pve-spice-connect
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = bash
+ depends = curl
+ depends = jq
+ depends = virt-viewer
+ provides = pve-spice-connect
+ source = git+https://gitlab.com/pawlakm/pve-spice-connect.git
+ sha256sums = SKIP
+
+pkgname = pve-spice-connect-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80f9d9ace1b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: <_@_._>
+
+pkgname=pve-spice-connect-git
+pkgver=r11.bebc2e4
+pkgrel=1
+pkgdesc="A bash script to easily connect to Proxmox PVE virtual machines via SPICE."
+arch=('x86_64')
+url="https://gitlab.com/pawlakm/pve-spice-connect"
+license=('GPL3')
+provides=('pve-spice-connect')
+depends=('bash' 'curl' 'jq' 'virt-viewer')
+makedepends=('git')
+source=("git+https://gitlab.com/pawlakm/pve-spice-connect.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/doc/${pkgname%-git}/"
+ install -Dm755 "pvespiceconnect.sh" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname%-git}/README.md"
+}