summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..074afe24384b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pyenv-virtualenvwrapper
+ pkgdesc = An alternative approach to manage virtualenvs from pyenv.
+ pkgver = 20140609
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/pyenv/pyenv-virtualenvwrapper
+ arch = any
+ license = MIT
+ depends = pyenv
+ depends = python-virtualenvwrapper
+ depends = bash
+ source = https://github.com/pyenv/pyenv-virtualenvwrapper/archive/v20140609.tar.gz
+ md5sums = 35dcafed8b60ad94e597fae8638c16c9
+
+pkgname = pyenv-virtualenvwrapper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1b94e7d9518d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Sources
+src/
+*.tar.gz
+
+# Built package
+pkg/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5c8461de019
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marc Demierre <marc.demierre@gmail.com>
+pkgname=pyenv-virtualenvwrapper
+pkgver=20140609
+pkgrel=1
+epoch=0
+pkgdesc="An alternative approach to manage virtualenvs from pyenv."
+arch=('any')
+url="https://github.com/pyenv/pyenv-virtualenvwrapper"
+license=('MIT')
+depends=('pyenv' 'python-virtualenvwrapper' 'bash')
+source=("https://github.com/pyenv/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('35dcafed8b60ad94e597fae8638c16c9')
+
+package() {
+ mkdir -p "${pkgdir?}"/{opt/pyenv/plugins/pyenv-virtualenvwrapper,usr/bin}
+ cd "${srcdir?}/$pkgname-$pkgver"
+ cp -a -- * "$pkgdir"/opt/pyenv/plugins/pyenv-virtualenvwrapper
+
+ for bin in $pkgdir/opt/pyenv/plugins/pyenv-virtualenvwrapper/bin/*; do
+ ln -s /opt/pyenv/plugins/pyenv-virtualenvwrapper/bin/"$(basename $bin)" "$pkgdir/usr/bin/$(basename $bin)"
+ done
+
+ # License
+ mkdir -p "$pkgdir"/usr/share/licenses/pyenv-virtualenvwrapper
+ cp LICENSE "$pkgdir"/usr/share/licenses/pyenv-virtualenvwrapper
+}
+