summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD19
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79d61e602ce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pygmy-static-bin
+ pkgdesc = Amazee.io's local docker development tool
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/pygmystack/pygmy
+ arch = x86_64
+ license = MIT
+ makedepends = tar
+ provides = pygmy
+ conflicts = pygmy
+ conflicts = pygmy-bin
+ conflicts = pygmy-git
+ conflicts = pygmy-go
+ conflicts = pygmy-go-bin
+ conflicts = pygmy-go-git
+ source = pygmy_0.8.0::https://github.com/pygmystack/pygmy/releases/download/v0.8.0/pygmy-go_0.8.0_linux_amd64_static.tar.gz
+ sha512sums = d82afffdbecc0ebfc2425de3ccba6faa7c571027127f1fc2164428a3b0c29cfe6f5ff856c2eca7c7e541f9040b23543f3df0932301da73dc04d8376d395ed0d5
+
+pkgname = pygmy-static-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87a36830d0a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+.idea/*
+pkg/*
+src/*
+pygmy* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..916b2291a401
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+// Copyright © 2019 Karl Hepworth <Karl.Hepworth@gmail.com>
+//
+// Permission is hereby granted, free of charge, to any person obtaining a copy
+// of this software and associated documentation files (the "Software"), to
+// deal in the Software without restriction, including without limitation the
+// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+// sell copies of the Software, and to permit persons to whom the Software is
+// furnished to do so, subject to the following conditions:
+//
+// The above copyright notice and this permission notice shall be included in
+// all copies or substantial portions of the Software.
+//
+// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+// IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+// FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+// AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+// LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+// FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+// IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd9ed5fdb766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: fubarhouse
+pkgname=pygmy-static-bin
+cleanname=pygmy
+provides=(pygmy)
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Amazee.io's local docker development tool"
+arch=('x86_64')
+url="https://github.com/pygmystack/pygmy"
+license=('MIT')
+conflicts=(pygmy pygmy-bin pygmy-git pygmy-go pygmy-go-bin pygmy-go-git)
+makedepends=('tar')
+source=("${cleanname}_${pkgver}::${url}/releases/download/v${pkgver}/${cleanname}-go_${pkgver}_linux_amd64_static.tar.gz")
+sha512sums=('d82afffdbecc0ebfc2425de3ccba6faa7c571027127f1fc2164428a3b0c29cfe6f5ff856c2eca7c7e541f9040b23543f3df0932301da73dc04d8376d395ed0d5')
+
+package() {
+ mkdir -p $pkgdir/usr/local/bin
+ install -Dm755 ${cleanname}-go "$pkgdir/usr/bin/$cleanname"
+}