summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21e21f7e886f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pypy3-gast
+ pkgdesc = AST that abstracts the underlying Python version
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://github.com/serge-sans-paille/gast
+ arch = any
+ license = BSD
+ makedepends = pypy3-setuptools
+ depends = pypy3
+ source = https://pypi.io/packages/source/g/gast/gast-0.5.3.tar.gz
+ sha512sums = a836be76303591ca7c40596d98a29dbd53f281e277c8c23e3821b2003d4e8aaf4d806e7f532f27c0eadd4bdca5a28dc0a3902245505ab97497b9afbfee0c2e52
+
+pkgname = pypy3-gast
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..026a428b72c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=pypy3-gast
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="AST that abstracts the underlying Python version "
+url="https://github.com/serge-sans-paille/gast"
+arch=(any)
+license=('BSD')
+depends=('pypy3')
+makedepends=('pypy3-setuptools')
+source=("https://pypi.io/packages/source/g/gast/gast-${pkgver}.tar.gz")
+sha512sums=('a836be76303591ca7c40596d98a29dbd53f281e277c8c23e3821b2003d4e8aaf4d806e7f532f27c0eadd4bdca5a28dc0a3902245505ab97497b9afbfee0c2e52')
+
+build() {
+ cd gast-$pkgver
+ pypy3 setup.py build
+}
+
+package() {
+ cd gast-$pkgver
+ pypy3 setup.py install --prefix=/opt/pypy3 --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}