summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--sipbin_fix.patch22
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6292bad2c2d9..6927bf28f0a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Feb 13 12:41:02 UTC 2019
pkgbase = pyqt3
pkgdesc = A set of Python bindings for the Qt3 toolkit
pkgver = 3.18.1
- pkgrel = 14
+ pkgrel = 15
url = http://www.riverbankcomputing.com/software/pyqt/intro
arch = i686
arch = x86_64
license = GPL
+ makedepends = python2-sip418
+ makedepends = sip418
depends = python2-sip
depends = qscintilla-qt3
source = http://downloads.sourceforge.net/project/pyqt/PyQt3/PyQt-x11-gpl-3.18.1.tar.gz
source = sip415_fix.patch
+ source = sipbin_fix.patch
md5sums = f1d120495d1aaf393819e988c0a7bb7e
md5sums = d695dc23d2211a97d3631ec82d8afd67
+ md5sums = 6cceabd8b41aa2514a7186a2589a4fb6
pkgname = pyqt3
diff --git a/PKGBUILD b/PKGBUILD
index 8e7b77e18733..43ce19cea552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# $Id: PKGBUILD 89515 2013-04-29 16:41:19Z spupykin $
-# Maintainer: AppleBloom <rat.o.drat@gmail.com>
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: AppleBloom <rat.o.drat@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
pkgname=pyqt3
pkgver=3.18.1
-pkgrel=14
+pkgrel=15
pkgdesc="A set of Python bindings for the Qt3 toolkit"
arch=('i686' 'x86_64')
url="http://www.riverbankcomputing.com/software/pyqt/intro"
depends=('python2-sip' 'qscintilla-qt3')
+makedepends=('python2-sip418' 'sip418')
license=('GPL')
source=("http://downloads.sourceforge.net/project/pyqt/PyQt3/PyQt-x11-gpl-${pkgver}.tar.gz"
- "sip415_fix.patch")
+ "sip415_fix.patch"
+ "sipbin_fix.patch")
md5sums=('f1d120495d1aaf393819e988c0a7bb7e'
- 'd695dc23d2211a97d3631ec82d8afd67')
+ 'd695dc23d2211a97d3631ec82d8afd67'
+ '6cceabd8b41aa2514a7186a2589a4fb6')
_dir="PyQt-x11-gpl-${pkgver}"
prepare() {
cd "$_dir"
- patch -p0 -i "../sip415_fix.patch"
+ patch -p0 -i "${srcdir}/sip415_fix.patch"
+ patch -p2 -i "${srcdir}/sipbin_fix.patch"
}
build() {
@@ -32,7 +36,7 @@ build() {
-d /usr/lib/python2.7/site-packages \
-v /usr/share/sip \
INCDIR_QT=/usr/include/qt3
- make CXX="g++ -DANY=void"
+ make CXX="g++ -DANY=void -I/usr/include/python2.7/sip418"
}
package() {
diff --git a/sipbin_fix.patch b/sipbin_fix.patch
new file mode 100644
index 000000000000..2732caf32b42
--- /dev/null
+++ b/sipbin_fix.patch
@@ -0,0 +1,22 @@
+diff -aur src.orig/PyQt-x11-gpl-3.18.1/build.py src/PyQt-x11-gpl-3.18.1/build.py
+--- src.orig/PyQt-x11-gpl-3.18.1/build.py 2019-02-13 11:52:42.295669716 +0100
++++ src/PyQt-x11-gpl-3.18.1/build.py 2019-02-13 11:52:57.308916413 +0100
+@@ -42,6 +42,7 @@
+ sys.exit(1)
+
+ config = sipconfig.SIPConfig("PyQt 3.18.1")
++config.sip_bin = '/usr/bin/sip418'
+
+
+ # Initialise the globals.
+diff -aur src.orig/PyQt-x11-gpl-3.18.1/configure.py src/PyQt-x11-gpl-3.18.1/configure.py
+--- src.orig/PyQt-x11-gpl-3.18.1/configure.py 2019-02-13 11:52:42.295669716 +0100
++++ src/PyQt-x11-gpl-3.18.1/configure.py 2019-02-13 11:53:09.368846036 +0100
+@@ -67,6 +67,7 @@
+
+ # Get the SIP configuration.
+ sipcfg = sipconfig.Configuration()
++sipcfg.sip_bin = '/usr/bin/sip418'
+
+ # Command line options.
+ opt_qtlib = None