summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c408204d2ef..83c25023933c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyradio-git
- pkgdesc = Command line internet radio player
- pkgver = 0.8.5.r0.g058bbe3
+ pkgdesc = Internet radio player for the command line
+ pkgver = 0.8.7.3.r0.g18cd1f0
pkgrel = 1
url = http://www.coderholic.com/pyradio/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index e2aed5a0bebc..b1bbc3bca9b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
# Contributor: sng <sng at hellug dot gr>
# Contributor: aksr <aksr at t-com dot me>
-_pkgname=pyradio
-pkgname=$_pkgname-git
-pkgver=0.8.7.r0.ga9b808f
+pkgname=pyradio-git
+pkgver=0.8.7.3.r0.g18cd1f0
pkgrel=1
-pkgdesc="Command line internet radio player"
+pkgdesc="Internet radio player for the command line"
arch=('any')
url="http://www.coderholic.com/pyradio/"
license=('MIT')
depends=('ncurses' 'python')
optdepends=('mplayer: as backend' 'vlc: as backend' 'mpv: as backend')
makedepends=('git' 'python-setuptools')
-provides=($_pkgname)
-conflicts=($_pkgname)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=($pkgname::git+https://github.com/coderholic/pyradio.git)
md5sums=('SKIP')
+prepare() {
+ cd $pkgname
+ _descr="$(git describe --long --tags)"
+ sed -i "s/git_description = ''/git_description = '$_descr'/" pyradio/radio.py
+}
+
pkgver() {
cd $pkgname
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
@@ -26,17 +31,13 @@ pkgver() {
package() {
cd $pkgname
- _descr="$(git describe --long --tags)"
- sed -i "s/git_description = ''/git_description = '$_descr'/" pyradio/radio.py
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
- install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
- install -Dm644 README.html "$pkgdir/usr/share/doc/pyradio/README.html"
- install -Dm644 README.md "$pkgdir/usr/share/doc/pyradio/README.md"
- install -Dm644 build.html "$pkgdir/usr/share/doc/pyradio/build.html"
- install -Dm644 build.md "$pkgdir/usr/share/doc/pyradio/build.md"
+ install -dm755 "$pkgdir/usr/share/doc/pyradio"
+ install -m644 README.{html,md} build.{html,md} "$pkgdir/usr/share/doc/pyradio"
- gzip pyradio.1
- install -Dm644 pyradio.1.gz "$pkgdir/usr/share/man/man1/pyradio.1.gz"
+ install -dm755 "$pkgdir/usr/share/man/man1"
+ gzip pyradio.1 > "$pkgdir/usr/share/man/man1/${pkgname%-git}.1.gz"
python setup.py install --root="$pkgdir" --optimize=1
}