summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 8 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31cdfbda99ed..8e42a9796445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pysbf-git
pkgdesc = Python module to parse Septentrio Binary Format (SBF) files generated by Septentrio receivers.
- pkgver = 20140606
+ pkgver = 20210821
pkgrel = 1
url = https://github.com/jashandeep-sohi/pysbf
arch = i686
@@ -8,6 +8,7 @@ pkgbase = pysbf-git
license = GPL3
makedepends = git
depends = python2
+ source = pysbf-git::git+https://github.com/jashandeep-sohi/pysbf.git
+ sha256sums = SKIP
pkgname = pysbf-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a2489b5cb56f..dab552c15c17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Arnhold <thomas at arnhold dot org>
pkgname=pysbf-git
-pkgver=20140606
+pkgver=20210821
pkgrel=1
pkgdesc="Python module to parse Septentrio Binary Format (SBF) files generated by Septentrio receivers."
arch=('i686' 'x86_64')
@@ -9,30 +9,15 @@ url="https://github.com/jashandeep-sohi/pysbf"
license=('GPL3')
depends=('python2')
makedepends=('git')
-
-_gitroot="git://github.com/jashandeep-sohi/pysbf.git"
-_gitname="pysbf"
+source=("$pkgname::git+https://github.com/jashandeep-sohi/pysbf.git")
+sha256sums=('SKIP')
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
python2 setup.py build
-
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
python2 setup.py install --prefix=/usr --root="$pkgdir"
}