summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a33e7d8b2d8..fc137239a51f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = python-abjad
pkgdesc = Tool for formalized music score control.
pkgver = 2.21
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Abjad/abjad
arch = any
license = GPL 3
makedepends = python-setuptools
makedepends = python2-setuptools
depends = lilypond
- optdepends = graphviz: to create rhythm-trees graphs and other tree structures
optdepends = fluidsynth: to play generated MIDI files (instead of timidity++)
optdepends = timidity++: to play generated MIDI files (instead of fluidsynth)
- optdepends = jupyter: browser-based interactive notebook for programming
- optdepends = ipython: an enhanced Python console
- optdepends = python-ipywidgets: IPython widgets for Jupyter notebook
- optdepends = python-pypdf2: PDF toolkit
+ optdepends = graphviz: to create rhythm-trees graphs and other tree structures
conflicts = python2-abjad
source = https://github.com/Abjad/abjad/archive/v2.21.tar.gz
sha256sums = 5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b
diff --git a/PKGBUILD b/PKGBUILD
index 3e8a1c59b038..fcf5f764ead7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-abjad
pkgname=(python-abjad python2-abjad)
pkgver=2.21
-pkgrel=3
+pkgrel=4
pkgdesc="Tool for formalized music score control."
arch=("any")
url="https://github.com/Abjad/abjad"
@@ -12,13 +12,9 @@ depends=("lilypond")
makedepends=("python-setuptools" "python2-setuptools")
conflicts=("python2-abjad")
optdepends=(
- "graphviz: to create rhythm-trees graphs and other tree structures"
"fluidsynth: to play generated MIDI files (instead of timidity++)"
"timidity++: to play generated MIDI files (instead of fluidsynth)"
- "jupyter: browser-based interactive notebook for programming"
- "ipython: an enhanced Python console"
- "python-ipywidgets: IPython widgets for Jupyter notebook"
- "python-pypdf2: PDF toolkit"
+ "graphviz: to create rhythm-trees graphs and other tree structures"
)
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=("5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b")
@@ -44,7 +40,7 @@ package_python-abjad() {
conflicts=("python2-abjad")
cd $srcdir/abjad-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --no-compile
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -63,7 +59,7 @@ package_python2-abjad() {
provides=("python-abjad")
cd $srcdir/abjad-$pkgver-python2
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --no-compile
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}