summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..018e622212b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-activipy-git
+ pkgdesc = ActivityStreams 2.0 python implementation and validation lib
+ pkgver = v0.1.r16.g270bab2
+ pkgrel = 1
+ url = http://activipy.readthedocs.io/en/latest/index.html
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-pyld
+ provides = python-activipy
+ conflicts = python-activipy
+ source = git://github.com/w3c-social/activipy.git
+ md5sums = SKIP
+
+pkgname = python-activipy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..66e8329dadc1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+activipy
+src
+pkg
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc02a1c36b02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=python-activipy-git
+_pkgname=activipy
+pkgver=v0.1.r16.g270bab2
+pkgrel=1
+pkgdesc='ActivityStreams 2.0 python implementation and validation lib'
+arch=('any')
+url='http://activipy.readthedocs.io/en/latest/index.html'
+license=('GPL3')
+depends=('python-pyld')
+makedepends=('git')
+conflicts=('python-activipy')
+provides=('python-activipy')
+source=('git://github.com/w3c-social/activipy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+ python setup.py install --root=${pkgdir} --optimize=1
+ install -D -m644 gpl-3.0.txt ${pkgdir}/usr/share/licenses/python-activipy
+}