summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a46ac6004b0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-anyconfig-json5-backend
+ pkgdesc = AA backend module for python-anyconfig to support to load and dump JSON5 (JSON for humans) data
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/ssato/python-anyconfig-json5-backend
+ arch = any
+ license = MIT
+ depends = python-anyconfig
+ source = https://files.pythonhosted.org/packages/source/a/anyconfig-json5-backend/anyconfig-json5-backend-0.2.0.tar.gz
+ sha256sums = 418f767a3151a9311cd538446bf4f67590fe3b2164fe67f1bee0794532c54481
+
+pkgname = python-anyconfig-json5-backend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..581d57017c45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+_name=anyconfig-json5-backend
+pkgname=python-$_name
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="AA backend module for python-anyconfig to support to load and dump JSON5 (JSON for humans) data"
+url='https://github.com/ssato/python-anyconfig-json5-backend'
+arch=('any')
+license=('MIT')
+depends=('python-anyconfig')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('418f767a3151a9311cd538446bf4f67590fe3b2164fe67f1bee0794532c54481')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
+}