summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6759b45021b..1add3267ce5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = python-astral
pkgdesc = Calculations for the position of the sun and moon.
- pkgver = 1.10
+ pkgver = 1.10.1
pkgrel = 1
url = https://github.com/sffjunkie/astral
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/a/astral/astral-1.10.tar.gz
- sha256sums = 8ef9e2346befb46867ccda69fe10b430dda13740b35e41016bfe5eec64d53e64
+ source = https://files.pythonhosted.org/packages/source/a/astral/astral-1.10.1.tar.gz
+ sha256sums = d2a67243c4503131c856cafb1b1276de52a86e5b8a1d507b7e08bee51cb67bf1
pkgname = python-astral
- depends = python-requests
depends = python-pytz
+ optdepends = python-requests: for Google geocoding support
pkgname = python2-astral
- depends = python2-requests
depends = python2-pytz
+ optdepends = python2-requests: for Google geocoding support
diff --git a/PKGBUILD b/PKGBUILD
index ef4748394698..d77055517601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase='python-astral'
pkgname=('python-astral' 'python2-astral')
_name='astral'
-pkgver=1.10
+pkgver=1.10.1
pkgrel=1
pkgdesc="Calculations for the position of the sun and moon."
url="https://github.com/sffjunkie/astral"
@@ -12,17 +12,19 @@ makedepends=('python-setuptools' 'python2-setuptools')
license=('Apache')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('8ef9e2346befb46867ccda69fe10b430dda13740b35e41016bfe5eec64d53e64')
+sha256sums=('d2a67243c4503131c856cafb1b1276de52a86e5b8a1d507b7e08bee51cb67bf1')
package_python-astral() {
- depends=('python-requests' 'python-pytz')
+ depends=('python-pytz')
+ optdepends=('python-requests: for Google geocoding support')
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-astral() {
- depends=('python2-requests' 'python2-pytz')
+ depends=('python2-pytz')
+ optdepends=('python2-requests: for Google geocoding support')
cd "${srcdir}/${_name}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1