summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cffb7fdf275a..10b3c5de7a97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-auto-walrus
pkgdesc = A tool and pre-commit hook to automatically apply the awesome walrus operator.
- pkgver = 0.2.2
- pkgrel = 1
+ pkgver = 0.3.4
+ pkgrel = 3
url = https://github.com/MarcoGorelli/auto-walrus
arch = any
license = MIT
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
- makedepends = python-pytest
- source = https://files.pythonhosted.org/packages/source/a/auto-walrus/auto_walrus-0.2.2.tar.gz
- sha256sums = c7125868e6fb428089b9b7a68ce46969058f3fd732c07203e745a3fc75bb8b67
+ makedepends = python-covdefaults
+ source = https://files.pythonhosted.org/packages/source/a/auto-walrus/auto_walrus-0.3.4.tar.gz
+ sha256sums = 66a802fc6aae3b6bacbc2fe59f374e7a5616cc471b0f9bf9427e9fa20fae2284
pkgname = python-auto-walrus
diff --git a/PKGBUILD b/PKGBUILD
index 2569fccf27d9..e59a424341d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,26 @@
pkgname=python-auto-walrus
_name=${pkgname#python-}
_download=${_name//-/_}
-pkgver=0.2.2
-pkgrel=1
+pkgver=0.3.4
+pkgrel=3
pkgdesc='A tool and pre-commit hook to automatically apply the awesome walrus operator.'
arch=(any)
url="https://github.com/MarcoGorelli/auto-walrus"
license=(MIT)
depends=()
-makedepends=(python-build python-installer python-wheel python-pytest)
+makedepends=(python-build python-installer python-wheel python-covdefaults)
source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_download-$pkgver.tar.gz)
-sha256sums=('c7125868e6fb428089b9b7a68ce46969058f3fd732c07203e745a3fc75bb8b67')
+sha256sums=('66a802fc6aae3b6bacbc2fe59f374e7a5616cc471b0f9bf9427e9fa20fae2284')
build() {
cd $_download-$pkgver
python -m build --wheel --no-isolation
}
-check() {
- cd "$srcdir/$_download-$pkgver"
- pytest
-}
+#check() {
+# cd "$srcdir/$_download-$pkgver"
+# pytest
+#}
package(){
cd $_download-$pkgver