summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdce1aac2bc5..7341822c7440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = python-backports.cached_property
url = https://github.com/penguinolog/backports.cached_property
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-setuptools-scm
makedepends = python-wheel
diff --git a/PKGBUILD b/PKGBUILD
index 501192c4508c..775d27d38b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,30 +7,32 @@ pkgver=1.0.2
pkgrel=1
pkgdesc="Python 3.8 functools.cached_property backport to python 3.6."
-arch=('any')
-license=('MIT')
+arch=("any")
+license=("MIT")
url="https://github.com/penguinolog/backports.cached_property"
source=("$url/archive/refs/tags/$pkgver.tar.gz")
sha512sums=('393272e93f97783d575268e19005d3295570dfc562afe179b6d4ac56960b57b71454639f3588a1dcd531e0871fc7b6fa91bbd854ad4f1c16875f1d6d75cb0aa2')
-depends=('python')
+depends=("python")
makedepends=(
- 'python-setuptools'
- 'python-setuptools-scm'
- 'python-wheel'
+ "python-build"
+ "python-installer"
+ "python-setuptools"
+ "python-setuptools-scm"
+ "python-wheel"
)
build ()
{
- export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver" || exit
+ SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver} \
+ python -m build --wheel --no-isolation
}
package ()
{
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}