summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..861ec039f78b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-backports.shutil_which
+ pkgdesc = Backport of shutil.which from Python 3.3
+ pkgver = 3.5.2
+ pkgrel = 1
+ url = https://github.com/minrk/backports.shutil_which
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = python-backports.shutil_which-3.5.2.tar.gz::https://github.com/minrk/backports.shutil_which/archive/refs/tags/3.5.2.tar.gz
+ b2sums = b78e3ddef7028dcec1f162157c021509582b2a5b8a828a9935349432cca72a2a07e123d907ab99a9c608b126d6dabae4e74adc8e62960e506de7bfb0dfeb2fd9
+
+pkgname = python-backports.shutil_which
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38e3a05343a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+#Maintainer digital mystik <echo ZGlnaXRhbF9teXN0aWtAcHJvdG9ubWFpbC5jaAo= | base64 -d>
+
+_name=backports.shutil_which
+pkgname=python-backports.shutil_which
+pkgver=3.5.2
+pkgrel=1
+pkgdesc="Backport of shutil.which from Python 3.3"
+arch=('any')
+url="https://github.com/minrk/backports.shutil_which"
+license=("GPL3")
+depends=('python')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/minrk/$_name/archive/refs/tags/$pkgver.tar.gz")
+
+b2sums=('b78e3ddef7028dcec1f162157c021509582b2a5b8a828a9935349432cca72a2a07e123d907ab99a9c608b126d6dabae4e74adc8e62960e506de7bfb0dfeb2fd9')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}