summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b42d678d1a28..0886d20fb944 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-better-exceptions
pkgdesc = Pretty and helpful exceptions, automatically
pkgver = 0.3.3
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Qix-/better-exceptions
arch = any
license = MIT
@@ -12,6 +12,6 @@ pkgbase = python-better-exceptions
makedepends = python-wheel
depends = python
source = python-better-exceptions-0.3.3.tar.gz::https://github.com/Qix-/better-exceptions/archive/refs/tags/0.3.3.tar.gz
- sha256sums = e4e6bc18444d5f04e6e894b10381e5e921d3d544240418162c7db57e9eb3453b
+ sha256sums = c4751169b2cc02455738a6c71a3de165145aa9572c833e67556008a205820468
pkgname = python-better-exceptions
diff --git a/PKGBUILD b/PKGBUILD
index c562e32bdc19..537e276680d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
# Contributor: mdraw.gh at gmail dot com
_name=better-exceptions
-_old_name=better_exceptions
pkgname=python-${_name}
pkgver=0.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="Pretty and helpful exceptions, automatically"
arch=('any')
url="https://github.com/Qix-/${_name}"
@@ -18,10 +17,10 @@ checkdepends=(
'python-pytest'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('e4e6bc18444d5f04e6e894b10381e5e921d3d544240418162c7db57e9eb3453b')
+sha256sums=('c4751169b2cc02455738a6c71a3de165145aa9572c833e67556008a205820468')
build() {
- cd "${_old_name}-${pkgver}"
+ cd "${_name}-${pkgver}"
python -m build --wheel --no-isolation
}
@@ -39,6 +38,6 @@ package() {
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \
- "$_site/${_old_name}-$pkgver.dist-info/LICENSE.txt" \
+ "$_site/${_name}-$pkgver.dist-info/LICENSE.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}