summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea4000fac512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-bitmath
+ pkgdesc = Python module for representing and manipulating file sizes with different prefix notations (file size unit conversion)
+ pkgver = 1.3.3.1
+ pkgrel = 1
+ url = https://github.com/tbielawa/bitmath
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/b/bitmath/bitmath-1.3.3.1.tar.gz
+ sha256sums = 293325f01e65defe966853111df11d39215eb705a967cb115851da8c4cfa3eb8
+
+pkgname = python-bitmath
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c230193ac7b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74cbb5d31cc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+pkgbase='python-bitmath'
+pkgname=('python-bitmath')
+_module='bitmath'
+pkgver='1.3.3.1'
+pkgrel=1
+pkgdesc="Python module for representing and manipulating file sizes with different prefix notations (file size unit conversion)"
+url="https://github.com/tbielawa/bitmath"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('293325f01e65defe966853111df11d39215eb705a967cb115851da8c4cfa3eb8')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}