summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..740e953d3810
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-brokenaxes
+ pkgdesc = Create broken axes
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/bendichter/brokenaxes
+ arch = any
+ license = MIT
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.8
+ depends = python-matplotlib>3.6
+ noextract = brokenaxes-0.6.2-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/b/brokenaxes/brokenaxes-0.6.2-py3-none-any.whl
+ sha256sums = bc0a269c4a9a9a643504fbb7d734a279629cc2cada5ee90c57645e75c89f38ad
+
+pkgname = python-brokenaxes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ce237576d50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+
+_name=brokenaxes
+pkgname=python-${_name,,}
+pkgver=0.6.2
+pkgrel=1
+pkgdesc='Create broken axes'
+arch=('any')
+url="https://github.com/bendichter/brokenaxes"
+license=('MIT')
+depends=('python>=3.8'
+ 'python-matplotlib>3.6')
+makedepends=('python-installer' 'python-wheel')
+_whl="${_name//-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
+sha256sums=(bc0a269c4a9a9a643504fbb7d734a279629cc2cada5ee90c57645e75c89f38ad)
+
+noextract=("$_whl")
+package() {
+ python -m installer --destdir="$pkgdir" "$_whl"
+}