summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8ac2bb2d239
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-captionstransformer-git
+ pkgdesc = Set of tools to transform captions from one format to another
+ pkgver = r29.6e33cab
+ pkgrel = 1
+ url = https://github.com/toutpt/captionstransformer
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python
+ depends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-soupsieve
+ provides = python-captionstransformer
+ conflicts = python-captionstransformer
+ source = git+https://github.com/toutpt/captionstransformer.git
+ md5sums = SKIP
+
+pkgname = python-captionstransformer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44938753ca81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Patrick Rogers <patrick@thewebzone.net>
+pkgname=python-captionstransformer-git
+_gitname='captionstransformer'
+pkgver=r29.6e33cab
+pkgrel=1
+pkgdesc="Set of tools to transform captions from one format to another"
+arch=('any')
+url="https://github.com/toutpt/captionstransformer"
+license=('GPL2')
+depends=('python' 'python-setuptools' 'python-beautifulsoup4' 'python-soupsieve')
+makedepends=('git')
+provides=("python-captionstransformer")
+conflicts=("python-captionstransformer")
+source=('git+https://github.com/toutpt/captionstransformer.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ python setup.py install --root="${pkgdir}"
+}