summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad67bb6eda92..f393f12dbda4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-casa-formats-io
pkgdesc = Code to handle I/O from/to data in CASA format Resources
- pkgver = 0.2.3
+ pkgver = 0.3.0
pkgrel = 1
url = https://casa-formats-io.readthedocs.io
arch = i686
arch = x86_64
license = LGPL-2.0-only
- checkdepends = python-pytest-openfiles
+ checkdepends = python-pytest
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
@@ -16,11 +16,11 @@ pkgbase = python-casa-formats-io
makedepends = python-sphinx-automodapi
makedepends = python-dask
makedepends = python-astropy
- source = https://files.pythonhosted.org/packages/source/c/casa_formats_io/casa_formats_io-0.2.3.tar.gz
- md5sums = a8c9ce1f163d7efb844253f7272990af
+ source = https://files.pythonhosted.org/packages/source/c/casa_formats_io/casa_formats_io-0.3.0.tar.gz
+ md5sums = d4406b7d5330afc4a3edeae0a99eb881
pkgname = python-casa-formats-io
- depends = python>=3.8
+ depends = python>=3.9
depends = python-astropy>=4.0
depends = python-dask>=2.0
diff --git a/PKGBUILD b/PKGBUILD
index fc1c3229d8b3..21f58af8cd87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-casa-formats-io
_pname=${pkgbase#python-}
_pyname=${_pname//-/_}
pkgname=("python-${_pname}" "python-${_pname}-doc")
-pkgver=0.2.3
+pkgver=0.3.0
pkgrel=1
pkgdesc="Code to handle I/O from/to data in CASA format Resources"
arch=('i686' 'x86_64')
@@ -18,9 +18,9 @@ makedepends=('python-setuptools-scm'
'python-sphinx-automodapi'
'python-dask'
'python-astropy')
-checkdepends=('python-pytest-openfiles') # astropy and dask already in makedepends. glue-core for pdepend. doctestplus will die for no glue-core
+checkdepends=('python-pytest') # astropy and dask already in makedepends. glue-core for pdepend. doctestplus will die for no glue-core
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('a8c9ce1f163d7efb844253f7272990af')
+md5sums=('d4406b7d5330afc4a3edeae0a99eb881')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -47,7 +47,7 @@ check() {
}
package_python-casa-formats-io() {
- depends=('python>=3.8' 'python-astropy>=4.0' 'python-dask>=2.0')
+ depends=('python>=3.9' 'python-astropy>=4.0' 'python-dask>=2.0')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"