summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 804468a96eaf..69fd8cded103 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-ccdproc
pkgdesc = Affiliated package for the AstroPy package for basic data reductions of CCD images
- pkgver = 2.4.1
+ pkgver = 2.4.2
pkgrel = 1
url = http://ccdproc.readthedocs.io
arch = any
- license = BSD
+ license = BSD-3-Clause
+ checkdepends = python-pytest-astropy-header
checkdepends = python-pytest-doctestplus
checkdepends = python-astroscrappy
checkdepends = python-scikit-image
@@ -15,12 +16,13 @@ pkgbase = python-ccdproc
makedepends = python-build
makedepends = python-installer
makedepends = python-sphinx-astropy
+ makedepends = python-matplotlib
makedepends = python-astropy
makedepends = python-scipy
makedepends = graphviz
- source = https://files.pythonhosted.org/packages/source/c/ccdproc/ccdproc-2.4.1.tar.gz
+ source = https://files.pythonhosted.org/packages/source/c/ccdproc/ccdproc-2.4.2.tar.gz
source = fix-underline-length.patch
- md5sums = eb5af074fbae4f29813eceedcfb76aec
+ md5sums = 9d8a0468c1308102401a0fec19587fcb
md5sums = 714badd0bef757818fda5babe233d235
pkgname = python-ccdproc
diff --git a/PKGBUILD b/PKGBUILD
index 911dd8f7519c..f8f853ebaec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,33 @@
pkgbase=python-ccdproc
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2.4.1
+pkgver=2.4.2
pkgrel=1
pkgdesc="Affiliated package for the AstroPy package for basic data reductions of CCD images"
arch=('any')
url="http://ccdproc.readthedocs.io"
-license=('BSD')
+license=('BSD-3-Clause')
makedepends=('python-setuptools-scm'
'python-wheel'
'python-build'
'python-installer'
'python-sphinx-astropy'
+ 'python-matplotlib'
'python-astropy'
'python-scipy'
# 'python-scikit-image'
# 'python-astroscrappy'
# 'python-reproject'
'graphviz')
-checkdepends=('python-pytest-doctestplus'
-# 'python-pytest-astropy-header'
+checkdepends=('python-pytest-astropy-header'
+ 'python-pytest-doctestplus'
'python-astroscrappy'
'python-scikit-image'
'python-reproject'
'python-memory-profiler') # psutil required by memory-profiler
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix-underline-length.patch')
-md5sums=('eb5af074fbae4f29813eceedcfb76aec'
+md5sums=('9d8a0468c1308102401a0fec19587fcb'
'714badd0bef757818fda5babe233d235')
prepare() {