summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae45c737a10..1a410160f63d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = python-ci_watson
pkgdesc = CI helper for STScI Jenkins
- pkgver = 0.6.1
+ pkgver = 0.6.2
pkgrel = 1
url = https://ci_watson.readthedocs.io
arch = any
license = BSD
checkdepends = python-pytest-astropy-header
- checkdepends = python-astropy
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
@@ -15,11 +14,12 @@ pkgbase = python-ci_watson
makedepends = python-numpydoc
makedepends = python-sphinx-automodapi
makedepends = python-crds
- source = https://github.com/spacetelescope/ci_watson/archive/0.6.1.tar.gz
- md5sums = bf36328cafcc5aad94d95bb5f7f46fac
+ makedepends = python-pytest
+ source = https://github.com/spacetelescope/ci_watson/archive/0.6.2.tar.gz
+ md5sums = 955fb8015bd126f0daaaa971d8f96a9e
pkgname = python-ci_watson
- depends = python>=3.5
+ depends = python>=3.9
depends = python-pytest>=3
depends = python-crds
optdepends = python-ci_watson-doc: Documentation for CI Watson
diff --git a/PKGBUILD b/PKGBUILD
index 7a317593f848..77834bd13d13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,31 @@
pkgbase=python-ci_watson
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=1
pkgdesc="CI helper for STScI Jenkins"
arch=('any')
url="https://ci_watson.readthedocs.io"
license=('BSD')
-makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer' 'python-sphinx_rtd_theme' 'python-numpydoc' 'python-sphinx-automodapi' 'python-crds')
-checkdepends=('python-pytest-astropy-header' 'python-astropy')
+makedepends=('python-setuptools-scm'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-sphinx_rtd_theme'
+ 'python-numpydoc'
+ 'python-sphinx-automodapi'
+ 'python-crds'
+ 'python-pytest')
+checkdepends=('python-pytest-astropy-header') # crds already in makedepends
source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz")
-md5sums=('bf36328cafcc5aad94d95bb5f7f46fac')
+md5sums=('955fb8015bd126f0daaaa971d8f96a9e')
+
+get_pyver() {
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
+}
prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
@@ -24,19 +35,18 @@ build() {
msg "Building Docs"
ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
- build/lib/${_pyname/-/_}-${pkgver}-py${_pyver}.egg-info
- cd ${srcdir}/${_pyname}-${pkgver}/docs
- PYTHONPATH="../build/lib" make html
+ build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver .).egg-info
+ PYTHONPATH="../build/lib" make -C docs html
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- PYTHONPATH="build/lib" pytest || warning "Tests failed"
+ PYTHONPATH="build/lib" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-ci_watson() {
- depends=('python>=3.5' 'python-pytest>=3' 'python-crds')
+ depends=('python>=3.9' 'python-pytest>=3' 'python-crds') # requests <- crds
optdepends=('python-ci_watson-doc: Documentation for CI Watson')
cd ${srcdir}/${_pyname}-${pkgver}