summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD56
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aff9c0c9457
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-cleo
+ pkgdesc = Cleo allows you to create beautiful and testable command-line interfaces
+ pkgver = 0.6.6
+ pkgrel = 1
+ url = https://github.com/sdispater/cleo
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-cleo-0.6.6.tar.gz::https://pypi.io/packages/source/c/cleo/cleo-0.6.6.tar.gz
+ source = https://raw.githubusercontent.com/sdispater/cleo/0.6.6/LICENSE
+ sha256sums = 1a848f6c56d143a3c4d46653522b559ebcd86b92af535418a1cb3e78ff5a8c4e
+ sha256sums = a2b9e0f3a35c5549b0b82edabcc0e229721437994d265cca96185e9f99f3a698
+
+pkgname = python-cleo
+ depends = python
+ depends = python-pastel
+ depends = python-pylev
+
+pkgname = python2-cleo
+ depends = python2
+ depends = python2-pastel
+ depends = python2-pylev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c878d9e3b796
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=cleo
+pkgbase='python-cleo'
+pkgname=('python-cleo' 'python2-cleo')
+pkgver=0.6.6
+pkgrel=1
+pkgdesc="Cleo allows you to create beautiful and testable command-line interfaces"
+arch=('any')
+url=https://github.com/sdispater/"${_name}"
+license=('MIT')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=(
+ "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
+ https://raw.githubusercontent.com/sdispater/cleo/0.6.6/LICENSE
+)
+sha256sums=(
+ '1a848f6c56d143a3c4d46653522b559ebcd86b92af535418a1cb3e78ff5a8c4e'
+ 'a2b9e0f3a35c5549b0b82edabcc0e229721437994d265cca96185e9f99f3a698'
+)
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+package() {
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-cleo() {
+ depends=('python2' 'python2-pastel' 'python2-pylev')
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-cleo() {
+ depends=('python' 'python-pastel' 'python-pylev')
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}