summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e56de30333b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-clickgen1
+ pkgdesc = X11 & Windows cursor building API (legacy 1.X.X version)
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/ful1e5/clickgen
+ arch = x86_64
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-pillow
+ depends = libx11
+ depends = libxcursor
+ depends = libpng
+ provides = xcursorgen.so
+ provides = python-clickgen
+ conflicts = python-clickgen
+ source = clickgen-1.2.0.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v1.2.0.tar.gz
+ sha256sums = 26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f
+
+pkgname = python-clickgen1
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57d302303edd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-clickgen1
+_name=clickgen
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="X11 & Windows cursor building API (legacy 1.X.X version)"
+arch=('x86_64')
+url="https://github.com/ful1e5/clickgen"
+license=('MIT')
+depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+provides=('xcursorgen.so' 'python-clickgen')
+conflicts=('python-clickgen')
+source=("$_name-$pkgver.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+
+ make -C src/xcursorgen
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -Dm644 src/xcursorgen/xcursorgen.so -t "${pkgdir}${site_packages}/$_name/"
+
+ install -d "$pkgdir/usr/share/licenses/python-clickgen"
+ ln -s "$site_packages/$_name-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/python-clickgen/"
+}