summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8d6b03be91a..21fa9ac82930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-colcon-notification
pkgdesc = An extension for colcon-core to provide status notifications.
- pkgver = 0.2.15
+ pkgver = 0.3.0
pkgrel = 1
url = https://pypi.org/project/colcon-notification
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = flake8
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/source/c/colcon-notification/colcon-notification-0.2.15.tar.gz
- sha256sums = 0a188a4debaa103f1fc620babb6f82a90032f01c559090ac51a5ff4cad326550
+ source = https://github.com/colcon/colcon-notification/archive/refs/tags/0.3.0.tar.gz
+ source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+ sha256sums = f82c6e3bcd558a9fbf4bf0b1cd0dab6a1f50c056b7b4db85c56878797d0489c2
+ sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-notification
diff --git a/PKGBUILD b/PKGBUILD
index 1308293df199..d4871c13953b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,36 @@
# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-notification
_name=${pkgname:7}
-pkgver=0.2.15
+pkgver=0.3.0
pkgrel=1
pkgdesc="An extension for colcon-core to provide status notifications."
arch=(any)
url="https://pypi.org/project/colcon-notification"
license=('Apache')
depends=('python-colcon-core')
-makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
-sha256sums=('0a188a4debaa103f1fc620babb6f82a90032f01c559090ac51a5ff4cad326550')
+makedepends=('python-setuptools' 'flake8')
+source=(
+ https://github.com/colcon/colcon-notification/archive/refs/tags/${pkgver}.tar.gz
+ https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+)
+sha256sums=(
+ 'f82c6e3bcd558a9fbf4bf0b1cd0dab6a1f50c056b7b4db85c56878797d0489c2'
+ '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082'
+)
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
+}
-package() {
+check() {
cd ${srcdir}/${_name}-${pkgver}
+ export PYTHONPATH="${srcdir}/scspell-2.2:${srcdir}/${_name}-${pkgver}"
+ ls test*.py | xargs -I {} pytest {}
+}
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 || echo "Not A Problem"
+package() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}