summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d329e1ca0b6..5d1d254f4938 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = python-corner
pkgdesc = Make some beautiful corner plots of samples
- pkgver = 2.2.1
+ pkgver = 2.2.2
pkgrel = 1
url = https://corner.readthedocs.io
arch = any
license = BSD
+ checkdepends = python-nose
makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
depends = python-matplotlib>=2.1
- depends = python-nose
- depends = python-pandas
optdepends = python-scipy
optdepends = python-arviz>=0.9
- optdepends = python-black
- optdepends = python-isort
- optdepends = python-toml
- source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.2.1.tar.gz
- md5sums = 4fc5208462aa3e4ba83f1e874382e287
+ source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.2.2.tar.gz
+ md5sums = 3d255640bde136724e1a516fb246367a
pkgname = python-corner
-
diff --git a/PKGBUILD b/PKGBUILD
index c85cecf182cf..aecda8474a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,38 @@
_pyname=corner
pkgname=python-${_pyname}
-pkgver=2.2.1
+pkgver=2.2.2
pkgrel=1
pkgdesc='Make some beautiful corner plots of samples'
url="https://corner.readthedocs.io"
-depends=('python-matplotlib>=2.1' 'python-nose' 'python-pandas')
-makedepends=('python-setuptools-scm')
-optdepends=('python-scipy' 'python-arviz>=0.9' 'python-black' 'python-isort' 'python-toml')
+depends=('python-matplotlib>=2.1')
+makedepends=('python-setuptools-scm'
+ 'python-wheel'
+ 'python-build'
+ 'python-installer')
+checkdepends=('python-nose')
+optdepends=('python-scipy' 'python-arviz>=0.9')
license=('BSD')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('4fc5208462aa3e4ba83f1e874382e287')
+md5sums=('3d255640bde136724e1a516fb246367a')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
+ nosetests
}
package() {
cd ${srcdir}/${_pyname}-${pkgver}
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1
+ install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}