summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1c5a413e637
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-cq_warehouse-git
+ pkgdesc = A cadquery parametric part collection, dev branch
+ pkgver = v0.6.0.r32.gbe12a7d
+ pkgrel = 1
+ url = https://github.com/gumyr/cq_warehouse
+ arch = x86_64
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = git
+ depends = python-cadquery
+ provides = python-cq_warehouse
+ conflicts = python-cq_warehouse
+ source = git+https://github.com/gumyr/cq_warehouse.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = python-cq_warehouse-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d72c38ee379d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+cq_warehouse/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a5ea20eec8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-cq_warehouse-git
+pkgver=v0.6.0.r32.gbe12a7d
+pkgrel=1
+pkgdesc="A cadquery parametric part collection, dev branch"
+arch=(x86_64)
+url="https://github.com/gumyr/cq_warehouse"
+license=('Apache')
+conflicts=(python-cq_warehouse)
+provides=(python-cq_warehouse)
+depends=(
+python-cadquery
+)
+makedepends=(
+python-build
+python-installer
+git
+)
+
+source=('git+https://github.com/gumyr/cq_warehouse.git#branch=dev')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd cq_warehouse
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd cq_warehouse
+ rm -rf dist # doesn't belong here
+}
+
+build() {
+ cd cq_warehouse
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd cq_warehouse
+ python -m unittest -v # project currently configured incorrectly for this to work
+}
+
+package() {
+ cd cq_warehouse
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ #python -m installer --destdir="${pkgdir}" dist/cq_warehouse-${pkgver}*.whl
+}
+