summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee0b3ad66314..e94bc5ce296b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-ctranslate2-bin
pkgdesc = CTranslate2 is a C++ and Python library for efficient inference with Transformer models.
- pkgver = 3.23.0
+ pkgver = 4.2.1
pkgrel = 1
url = https://github.com/OpenNMT/CTranslate2
arch = x86_64
license = MIT
- makedepends = python-pip
- depends = python>=3.7
+ depends = gcc-libs
depends = python-numpy
+ depends = python-pytorch
+ depends = python-setuptools
depends = python-yaml
provides = ctranslate2
conflicts = ctranslate2-git
conflicts = python-ctranslate2-git
- source = https://files.pythonhosted.org/packages/cp311/c/ctranslate2/ctranslate2-3.23.0-cp311-cp311-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
- sha256sums = cf8a0d3085297373208f6e703e096bfd3b19ec80bf133e006fdcd7e88996b11b
+ source = https://files.pythonhosted.org/packages/cp312/c/ctranslate2/ctranslate2-4.2.1-cp312-cp312-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ sha256sums = 1681fb06fa5714e3d440b4a9fce8f1fb71cfadfcc912e0346eaea4385269b347
pkgname = python-ctranslate2-bin
diff --git a/PKGBUILD b/PKGBUILD
index 53ba99b47b09..af9667ae0fe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: gilcu3
_pkgname=ctranslate2
pkgname=python-$_pkgname-bin
-pkgver=3.23.0
+pkgver=4.2.1
pkgrel=1
pkgdesc="CTranslate2 is a C++ and Python library for efficient inference with Transformer models."
arch=('x86_64')
@@ -9,15 +9,12 @@ url="https://github.com/OpenNMT/CTranslate2"
license=('MIT')
provides=("ctranslate2")
conflicts=('ctranslate2-git' 'python-ctranslate2-git')
-depends=('python>=3.7' 'python-numpy' 'python-yaml')
-makedepends=('python-pip')
-_py=cp311
+depends=('gcc-libs' 'python-numpy' 'python-pytorch' 'python-setuptools' 'python-yaml')
+_py=cp312
wheel_name=${_pkgname//-/_}-$pkgver-$_py-${_py}-manylinux_2_17_$arch.manylinux2014_$arch.whl
source=(https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/$wheel_name)
-sha256sums=('cf8a0d3085297373208f6e703e096bfd3b19ec80bf133e006fdcd7e88996b11b')
+sha256sums=('1681fb06fa5714e3d440b4a9fce8f1fb71cfadfcc912e0346eaea4385269b347')
package() {
- pip install --isolated --upgrade --no-deps --ignore-installed --root=$pkgdir --no-warn-script-location $wheel_name
- python -m compileall -d /usr "$pkgdir"/usr
- python -O -m compileall -d /usr "$pkgdir"/usr
+ python -m installer --destdir="$pkgdir" $wheel_name
}