summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a696810c776c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-cyhunspell
+ pkgdesc = Cython wrapper on Hunspell dictionary
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://github.com/MSeal/cython_hunspell
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-cacheman
+ source = https://github.com/MSeal/cython_hunspell/archive/2.0.2/python-cyhunspell-2.0.2.tar.gz
+ sha256sums = 4af1222113ec7142eee3689ddf95e26c6c72ffa585426b99a1de243ec61bd87c
+
+pkgname = python-cyhunspell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3638583ba372
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=python-cyhunspell
+pkgver=2.0.2
+pkgrel=1
+pkgdesc='Cython wrapper on Hunspell dictionary'
+arch=('x86_64')
+url='https://github.com/MSeal/cython_hunspell'
+license=('MIT')
+depends=('python-cacheman')
+makedepends=('python-setuptools' 'python-wheel')
+source=("https://github.com/MSeal/cython_hunspell/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('4af1222113ec7142eee3689ddf95e26c6c72ffa585426b99a1de243ec61bd87c')
+
+build() {
+ cd cython_hunspell-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd cython_hunspell-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}