summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ad89354dee9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-datarediset
+ pkgdesc = Python's dict on top of Redis
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/RcrdBrt/datarediset
+ arch = any
+ license = GPLv3
+ options = !emptydirs
+ source = https://github.com/RcrdBrt/datarediset/archive/0.0.4.tar.gz
+ sha256sums = c200c67a6286b948c825274399d0c17af1af35ada6446e0f5285b740c8449ae0
+
+pkgname = python-datarediset
+ depends = python
+ depends = python-redis
+ depends = redis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6583947828cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Riccardo Berto <riccardobrt@gmail.com>
+
+pkgname=('python-datarediset')
+_pkgname=('datarediset')
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Python's dict on top of Redis"
+arch=('any')
+url="https://github.com/RcrdBrt/datarediset"
+license=('GPLv3')
+options=('!emptydirs')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('c200c67a6286b948c825274399d0c17af1af35ada6446e0f5285b740c8449ae0')
+
+package() {
+ depends=('python' 'python-redis' 'redis')
+ cd ""$_pkgname-$pkgver""
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+