summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1abe950538d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-dateutil-git
+ pkgdesc = Provides powerful extensions to the standard datetime module
+ pkgver = 2.8.2
+ pkgrel = 1
+ url = https://github.com/dateutil/dateutil
+ arch = any
+ license = BSD
+ license = Apache
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-setuptools-scm
+ depends = python
+ depends = python-six
+ source = python-dateutil::git+https://github.com/dateutil/dateutil.git
+ sha256sums = SKIP
+
+pkgname = python-dateutil-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87964233b3fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name=python-dateutil-git
+pkgname=python-dateutil-git
+_pkgname=${pkgname%-git}
+pkgver=2.8.2
+pkgrel=1
+pkgdesc="Provides powerful extensions to the standard datetime module"
+arch=('any')
+license=('BSD' 'Apache')
+url="https://github.com/dateutil/dateutil"
+depends=('python' 'python-six')
+makedepends=('python-build' 'python-wheel' 'python-installer' 'python-setuptools-scm')
+source=("$_pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ echo "$pkgdir"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}