summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ab1e6f7c5de..4fca3ca59b14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-dateutils
- pkgdesc = Utilities for working with datetime objects.
+ pkgdesc = Utilities for working with datetime objects
pkgver = 0.6.12
- pkgrel = 1
- url = https://github.com/plytophogy/python-dateutils
+ pkgrel = 2
+ url = https://github.com/jmcantrell/python-dateutils
arch = any
license = ISC
+ makedepends = python-setuptools
depends = python-dateutil
- depends = python-argparse
depends = python-pytz
- source = https://files.pythonhosted.org/packages/source/d/dateutils/dateutils-0.6.12.tar.gz
- sha256sums = 03dd90bcb21541bd4eb4b013637e4f1b5f944881c46cc6e4b67a6059e370e3f1
+ source = python-dateutils-0.6.12.tar.gz::https://github.com/jmcantrell/python-dateutils/archive/refs/tags/v0.6.12.tar.gz
+ sha256sums = a7633f065542c5550e719622ac72f6f2d67e9b0a6af0d4b0cc13e0b9eab006aa
pkgname = python-dateutils
-
diff --git a/PKGBUILD b/PKGBUILD
index 32f9cbe1b684..649a2a18a037 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,23 @@
_pkgname=dateutils
pkgname=python-$_pkgname
pkgver=0.6.12
-pkgrel=1
-pkgdesc="Utilities for working with datetime objects."
+pkgrel=2
+pkgdesc="Utilities for working with datetime objects"
arch=('any')
-url="https://github.com/plytophogy/python-dateutils"
+url="https://github.com/jmcantrell/python-dateutils"
license=('ISC')
-depends=('python-dateutil' 'python-argparse' 'python-pytz')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('03dd90bcb21541bd4eb4b013637e4f1b5f944881c46cc6e4b67a6059e370e3f1')
+depends=('python-dateutil' 'python-pytz')
+makedepends=('python-setuptools')
+source=($pkgname-$pkgver.tar.gz::"$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('a7633f065542c5550e719622ac72f6f2d67e9b0a6af0d4b0cc13e0b9eab006aa')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" -O1 --skip-build
install -Dm755 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}