summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cffacde16fa..cb9c96c9f6b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
# Generated by mksrcinfo(replacement shim) v8
-# Thu Aug 12 11:03:30 AM EDT 2021
+# Sat May 13 09:08:43 PM PDT 2023
pkgbase = python-delete-tweets
pkgdesc = a simple script that helps you delete tweets (or just replies or retweets) from your timeline
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/koenrh/delete-tweets
arch = any
license = custom:isc
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-twitter3
depends = python-dateutil
diff --git a/PKGBUILD b/PKGBUILD
index 1b493ef7854e..e8a87dbc8394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
pkgname=python-delete-tweets
_pkgname=delete-tweets
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="a simple script that helps you delete tweets (or just replies or retweets) from your timeline"
url="https://github.com/koenrh/delete-tweets"
arch=('any')
license=('custom:isc')
depends=('python' 'python-twitter3' 'python-dateutil')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://github.com/koenrh/delete-tweets/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('cf19eae62899ce4573136d5c59a26e4b600bdf03129766b826255f5b1ec2e382')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}