summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6085321b9485..4d7dc98f7cd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-devito
pkgdesc = Finite Difference DSL for symbolic computation
- pkgver = 4.8.5
+ pkgver = 4.8.6
pkgrel = 1
url = https://github.com/devitocodes/devito
arch = any
@@ -10,16 +10,19 @@ pkgbase = python-devito
makedepends = python-setuptools
makedepends = python-wheel
makedepends = openmp
+ makedepends = git
+ depends = python-sympy
depends = python-cached-property
depends = python-psutil
depends = python-py-cpuinfo
depends = python-codepy
depends = python-multidict
depends = python-anytree
- depends = python-sympy
+ depends = python-cloudpickle
+ depends = python-click
optdepends = python-mpi4py: for parallel support
optdepends = python-ipyparallel: for parallel support
- source = devito-4.8.5.tar.gz::https://github.com/devitocodes/devito/archive/v4.8.5.tar.gz
- sha512sums = adc2fd7b6f3aa577b3287132e37f64e9997e2694fc62bf48d8f968ee1b46746cdcd75470e20ae9cc02ec235f12815a0fd1cde80c4ea22160e23529e5c018359a
+ source = devito-4.8.6.tar.gz::https://github.com/devitocodes/devito/archive/v4.8.6.tar.gz
+ sha512sums = 7c59990352742d35d32dd65aa45e953940382fb1c78577840d9d4841739326f958af3192229a29808bcdf6435e15ea4b383bd9975a3857a6acd17c982b2dc15f
pkgname = python-devito
diff --git a/PKGBUILD b/PKGBUILD
index 62987fc53d0a..cc3ab9706d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=devito
pkgname=python-${_base}
-pkgver=4.8.5
+pkgver=4.8.6
pkgrel=1
pkgdesc="Finite Difference DSL for symbolic computation"
arch=(any)
url="https://github.com/${_base}codes/${_base}"
license=(MIT)
-depends=(python-cached-property python-psutil python-py-cpuinfo
- python-codepy python-multidict python-anytree python-sympy)
-makedepends=(python-build python-installer python-setuptools python-wheel openmp)
-# checkdepends=(python-pytest python-scipy python-matplotlib python-nbval python-cloudpickle)
+depends=(python-sympy python-cached-property python-psutil python-py-cpuinfo
+ python-codepy python-multidict python-anytree python-cloudpickle python-click)
+makedepends=(python-build python-installer python-setuptools python-wheel openmp git)
+# checkdepends=(python-pytest python-scipy python-nbval python-matplotlib)
optdepends=('python-mpi4py: for parallel support'
- 'python-ipyparallel: for parallel support') # python-click
+ 'python-ipyparallel: for parallel support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('adc2fd7b6f3aa577b3287132e37f64e9997e2694fc62bf48d8f968ee1b46746cdcd75470e20ae9cc02ec235f12815a0fd1cde80c4ea22160e23529e5c018359a')
+sha512sums=('7c59990352742d35d32dd65aa45e953940382fb1c78577840d9d4841739326f958af3192229a29808bcdf6435e15ea4b383bd9975a3857a6acd17c982b2dc15f')
build() {
cd ${_base}-${pkgver}
@@ -26,8 +26,7 @@ build() {
# python -m venv --system-site-packages test-env
# test-env/bin/python -m installer dist/*.whl
# DEVITO_ARCH=gcc DEVITO_MPI=1 OMP_NUM_THREADS=1 \
-# test-env/bin/python -m pytest tests/test_mpi.py \
-# -k 'not partitioning and not partitioning_fewer_dims and not partitioning_fewer_dims_timefunc and not neighborhood_horizontal_2d and not neighborhood_diagonal_2d and not ctypes_neighborhood and not custom_topology and not halo_exchange_bilateral and not halo_exchange_bilateral_asymmetric[paddings0] and not halo_exchange_bilateral_asymmetric[paddings1]'
+# test-env/bin/python -m pytest tests/test_mpi.py
# }
package() {