summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d855669ce4f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-django-stdimage-git
+ pkgdesc = Django Standardized Image Field
+ pkgver = 3.0.0.r26.g4c7194a
+ pkgrel = 1
+ url = https://github.com/codingjoe/django-stdimage
+ arch = any
+ license = mit
+ checkdepends = python-pytest
+ checkdepends = python-pytest-runner
+ checkdepends = python-pytest-django
+ checkdepends = python-pytest-cov
+ depends = python-django
+ depends = python-pillow
+ depends = python-progressbar
+ provides = python-django-stdimage
+ source = python-django-stdimage-git::git+https://github.com/codingjoe/django-stdimage
+ md5sums = SKIP
+
+pkgname = python-django-stdimage-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f17df1390b96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Julian Daube <joposter (at) gmail (dot) com>
+# Contributor: Julian Daube <joposter (at) gmail (dot) com>
+pkgname=python-django-stdimage-git
+pkgver=3.0.0.r26.g4c7194a
+pkgrel=1
+pkgdesc="Django Standardized Image Field"
+
+provides=("python-django-stdimage")
+url="https://github.com/codingjoe/django-stdimage"
+arch=("any")
+license=("mit")
+
+source=("$pkgname::git+$url")
+depends=("python-django" "python-pillow" "python-progressbar")
+makepepends=("python-setuptools")
+checkdepends=("python-pytest" "python-pytest-runner" "python-pytest-django" "python-pytest-cov")
+
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "$pkgname"
+ env PYTHONPATH="$srcdir/$pkgname" pytest
+}
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/python-django-stdimage/LICENSE
+}
+
+md5sums=("SKIP")