summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f80e93b890d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-django-stubs-ext
+ pkgdesc = Extensions and monkey-patching for django-stubs.
+ pkgver = 4.2.7
+ pkgrel = 1
+ url = https://github.com/typeddjango/django-stubs
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-django
+ source = https://github.com/typeddjango/django-stubs/archive/refs/tags/4.2.7.tar.gz
+ sha256sums = 78c2750b95a877260b44354d43ff6eee8b516cdb909398df7e78da060cc42a78
+
+pkgname = python-django-stubs-ext
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf82386e3437
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ashley Bone <ashley DOT bone AT pm DOT me>
+pkgname=python-django-stubs-ext
+_pkgname=django-stubs
+pkgver=4.2.7
+pkgrel=1
+pkgdesc="Extensions and monkey-patching for django-stubs."
+arch=('any')
+url="https://github.com/typeddjango/django-stubs"
+license=('MIT')
+depends=(python-django)
+makedepends=(python-build
+ python-installer
+ python-setuptools
+ python-wheel)
+source=($url/archive/refs/tags/$pkgver.tar.gz)
+sha256sums=('78c2750b95a877260b44354d43ff6eee8b516cdb909398df7e78da060cc42a78')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/ext"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/ext"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}