summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a137dd5f289a..77ca5952e181 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-dnsimple
pkgdesc = Python client for DNSimple domain registration and DNS hosting
- pkgver = 0.3.6
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/onlyhavecans/dnsimple-python
arch = any
license = MIT
makedepends = python-pip
+ makedepends = git
depends = python
depends = python-requests
- source = https://github.com/onlyhavecans/dnsimple-python/archive/0.3.6.tar.gz
- md5sums = 2102b56025a75bb7c6dbdfc4d66b59fa
- sha256sums = 4a8fd76b83fadc282b8fd087af7c4f1f14657f880d71d5f06fe569cbbb0b3b11
+ source = git+https://github.com/onlyhavecans/dnsimple-python#tag=1.2.0
+ sha256sums = SKIP
pkgname = python-dnsimple
diff --git a/PKGBUILD b/PKGBUILD
index 170b4deae8e2..c8e2aadacde1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: itsme <mymail@ishere.ru>
-
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
pkgname=python-dnsimple
pkgdesc="Python client for DNSimple domain registration and DNS hosting"
-pkgver=0.3.6
+pkgver=1.2.0
pkgrel=1
arch=('any')
url="https://github.com/onlyhavecans/dnsimple-python"
license=('MIT')
-makedepends=('python-pip')
+makedepends=('python-pip' 'git')
depends=('python' 'python-requests')
-source=("https://github.com/onlyhavecans/dnsimple-python/archive/$pkgver.tar.gz")
-md5sums=('2102b56025a75bb7c6dbdfc4d66b59fa')
-sha256sums=('4a8fd76b83fadc282b8fd087af7c4f1f14657f880d71d5f06fe569cbbb0b3b11')
-
+source=("git+https://github.com/onlyhavecans/dnsimple-python#tag=${pkgver}")
+sha256sums=('SKIP')
package() {
- cd $srcdir/dnsimple-python-$pkgver
+ cd $srcdir/dnsimple-python
python setup.py install --root="$pkgdir/" --optimize=1
}