summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--fix-setup.cfg.patch10
3 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7c6b4f088be..a607440d3758 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = python-dotmap
pkgdesc = Ordered, dynamically-expandable dot-access dictionary
pkgver = 1.3.30
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/drgrib/dotmap
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
source = https://files.pythonhosted.org/packages/source/d/dotmap/dotmap-1.3.30.tar.gz
+ source = fix-setup.cfg.patch
sha256sums = 5821a7933f075fb47563417c0e92e0b7c031158b4c9a6a7e56163479b658b368
+ sha256sums = b2f1d6972fbd169684f36c4958f7167c81a85d4aab126c11d1fcad1bfbc121ee
pkgname = python-dotmap
diff --git a/PKGBUILD b/PKGBUILD
index 84991333ff80..95614c3ebfed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,31 @@
pkgname=python-dotmap
_name=dotmap
pkgver=1.3.30
-pkgrel=1
+pkgrel=2
pkgdesc="Ordered, dynamically-expandable dot-access dictionary"
arch=('any')
url="https://github.com/drgrib/dotmap"
license=('MIT')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5821a7933f075fb47563417c0e92e0b7c031158b4c9a6a7e56163479b658b368')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ fix-setup.cfg.patch)
+sha256sums=('5821a7933f075fb47563417c0e92e0b7c031158b4c9a6a7e56163479b658b368'
+ 'b2f1d6972fbd169684f36c4958f7167c81a85d4aab126c11d1fcad1bfbc121ee')
+
+prepare() {
+ cd "$_name-$pkgver"
+ patch -p1 < "$srcdir"/fix-setup.cfg.patch
+}
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/fix-setup.cfg.patch b/fix-setup.cfg.patch
new file mode 100644
index 000000000000..1790da833f53
--- /dev/null
+++ b/fix-setup.cfg.patch
@@ -0,0 +1,10 @@
+diff -u dotmap-1.3.30.orig/setup.cfg dotmap-1.3.30/setup.cfg
+--- dotmap-1.3.30.orig/setup.cfg 2023-07-30 14:29:47.356871660 +0200
++++ dotmap-1.3.30/setup.cfg 2023-07-30 14:30:13.563521346 +0200
+@@ -1,5 +1,5 @@
+ [metadata]
+-description-file = README.rst
++description_file = README.rst
+
+ [egg_info]
+ tag_build =