summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34a548266d1c..bd5e3185989b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-easyprocess
pkgdesc = easy to use python subprocess interface
- pkgver = 0.2.9
+ pkgver = 0.2.10
pkgrel = 1
url = https://github.com/ponty/EasyProcess
arch = any
license = BSD
+ makedepends = python-setuptools
depends = python
- depends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.9.tar.gz
- md5sums = a1008fc7b2cb69ff2f48a5fae201c24d
+ source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.10.tar.gz
+ sha256sums = 636b5e30222cde1e881fafc0112b35d516bce41ddee83ecbac656dec9befea1b
pkgname = python-easyprocess
-
diff --git a/PKGBUILD b/PKGBUILD
index 3cbbd410e2c7..c9502931ebee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
+# Maintainer: Hao Long <aur@esd.cc>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Michael Spradling <mike@mspradling.com>
_name=EasyProcess
pkgname=python-easyprocess
-pkgver=0.2.9
+pkgver=0.2.10
pkgrel=1
pkgdesc="easy to use python subprocess interface"
arch=(any)
url="https://github.com/ponty/EasyProcess"
license=('BSD')
-depends=('python' 'python-setuptools')
+depends=('python')
+makedepends=('python-setuptools')
source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
-md5sums=('a1008fc7b2cb69ff2f48a5fae201c24d')
+sha256sums=('636b5e30222cde1e881fafc0112b35d516bce41ddee83ecbac656dec9befea1b')
build() {
@@ -22,4 +24,5 @@ build() {
package() {
cd "${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}