summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61dae0b2bb6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-evelink
+ pkgdesc = Python bindings for the EVE API.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/eve-val/evelink
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-six
+ source = git+https://github.com/eve-val/evelink.git#tag=0.7.0
+ sha256sums = SKIP
+
+pkgname = python-evelink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b161607e3dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: James Denholm <nod.helm@gmail.com>
+pkgname=python-evelink
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Python bindings for the EVE API."
+arch=('any')
+url="https://github.com/eve-val/evelink"
+license=('MIT')
+depends=('python' 'python-six')
+makedepends=('git')
+options=()
+source=("git+https://github.com/eve-val/evelink.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+_gitname=evelink
+
+package() {
+ cd "$srcdir/$_gitname"
+ #Remove setup.py's handling of README.md, LICENSE, and bin/evelink
+ sed -i '33,35d;36d' setup.py
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ #Manually deal with the LICENSE file.
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: