summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 11 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b235c11b785b..b214ff43692d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
pkgbase = python-extinction
pkgdesc = Fast interstellar dust extinction laws in Python
- pkgver = 0.4.5
+ pkgver = 0.4.6
pkgrel = 1
url = http://extinction.readthedocs.io
arch = i686
arch = x86_64
license = MIT
makedepends = cython
- makedepends = cython2
+ makedepends = python-setuptools
makedepends = python-numpy
- makedepends = python2-numpy
- source = https://files.pythonhosted.org/packages/source/e/extinction/extinction-0.4.5.tar.gz
- md5sums = 697e804e83225bab3d4267fffd9a9054
+ source = https://files.pythonhosted.org/packages/source/e/extinction/extinction-0.4.6.tar.gz
+ md5sums = 8e0e541055cbf8f0794dbb2050d0958f
pkgname = python-extinction
depends = python-numpy>=1.13.3
-
-pkgname = python2-extinction
- depends = python2-numpy>=1.13.3
-
diff --git a/PKGBUILD b/PKGBUILD
index 2692a41f2a39..8f31150c29c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,28 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-extinction
_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}" "python2-${_pyname}")
-pkgver=0.4.5
+pkgname=("python-${_pyname}")
+pkgver=0.4.6
pkgrel=1
pkgdesc="Fast interstellar dust extinction laws in Python"
arch=('i686' 'x86_64')
url="http://extinction.readthedocs.io"
license=('MIT')
-makedepends=('cython' 'cython2' 'python-numpy' 'python2-numpy')
-#checkdepends=('python-pytest' 'python2-pytest')
+makedepends=('cython' 'python-setuptools' 'python-numpy')
+#checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('697e804e83225bab3d4267fffd9a9054')
-
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
-}
+md5sums=('8e0e541055cbf8f0794dbb2050d0958f')
build() {
- msg "Building Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py build
-
- msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
+
python setup.py build
}
check() {
- msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
- msg "Checking Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
-}
-
-package_python2-extinction() {
- depends=('python2-numpy>=1.13.3')
- cd ${srcdir}/${_pyname}-${pkgver}-py2
-
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python setup.py test
}
package_python-extinction() {