summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8626b52d3228..216108acd992 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fastkde
pkgdesc = Fast kernel density estimation
- pkgver = 1.0.20
+ pkgver = 1.0.26
pkgrel = 2
url = https://github.com/LBL-EESA/fastkde
arch = any
@@ -11,7 +11,7 @@ pkgbase = python-fastkde
depends = python-scipy
depends = cython
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/f/fastkde/fastkde-1.0.20.tar.gz
- sha256sums = 6b8256739e216d04c4283afa32f207981a0a1b5c1e6d9242675577f77fd00aab
+ source = https://files.pythonhosted.org/packages/source/f/fastkde/fastkde-1.0.26.tar.gz
+ sha256sums = 5dbfd7552040e669fc20ada349f5e9bf023a380851cbe10d30146de845a63693
pkgname = python-fastkde
diff --git a/PKGBUILD b/PKGBUILD
index e869d724c961..4a7dc04e04e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=python-fastkde
_name=${pkgname#python-}
-pkgver=1.0.20
+pkgver=1.0.26
pkgrel=2
pkgdesc="Fast kernel density estimation"
arch=(any)
@@ -17,9 +17,11 @@ backup=()
options=(!emptydirs)
install=
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=(6b8256739e216d04c4283afa32f207981a0a1b5c1e6d9242675577f77fd00aab)
+sha256sums=('5dbfd7552040e669fc20ada349f5e9bf023a380851cbe10d30146de845a63693')
build() {
cd "$srcdir/$_name-$pkgver"
+ sed -i 's/"oldest-supported-numpy.*"/"numpy"/' pyproject.toml
+ #sed -i 's:nspread/2:"nspread//2:' fastkde/nufft.pyx
python -m build --wheel --no-isolation
}