summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9669bd897cf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-fcl
+ pkgdesc = Python bindings for the Flexible Collision Library
+ pkgver = 0.7.0.5
+ pkgrel = 1
+ url = https://github.com/BerkeleyAutomation/python-fcl
+ arch = x86_64
+ license = GPL
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ provides = python-fcl
+ source_x86_64 = https://files.pythonhosted.org/packages/cp311/p/python-fcl/python_fcl-0.7.0.5-cp311-cp311-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ md5sums_x86_64 = f4286584d79f65d65a5319c49d43effb
+
+pkgname = python-fcl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b7758bcd84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cyril <cyrwae[at]hotmail[dot]com>
+pkgname=python-fcl
+pkgver=0.7.0.5
+pkgrel=1
+pkgdesc="Python bindings for the Flexible Collision Library"
+arch=('x86_64')
+url="https://github.com/BerkeleyAutomation/python-fcl"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(python-build python-installer python-wheel)
+optdepends=()
+provides=('python-fcl')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_py=cp311
+source_x86_64=(https://files.pythonhosted.org/packages/$_py/${pkgname::1}/$pkgname/${pkgname//-/_}-$pkgver-$_py-${_py}-manylinux_2_17_x86_64.manylinux2014_x86_64.whl)
+noextract=()
+md5sums_x86_64=('f4286584d79f65d65a5319c49d43effb')
+
+package() {
+ python -m installer --destdir="$pkgdir" *.whl
+}