summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..910de770ce9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-file-read-backwards
+ pkgdesc = Memory efficient way of reading files line-by-line from the end of file
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/RobinNil/file_read_backwards
+ arch = any
+ license = MIT
+ depends = python
+ source = python-file-read-backwards-2.0.0.tar.gz::https://github.com/RobinNil/file_read_backwards/archive/v2.0.0.tar.gz
+ md5sums = 38ee664ca2083ecf59fd09f4211c5406
+
+pkgname = python-file-read-backwards
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a99bf14414d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Benoît Allard <benoit.allard@gnx.de>
+pkgname=python-file-read-backwards
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Memory efficient way of reading files line-by-line from the end of file"
+arch=('any')
+url="https://github.com/RobinNil/file_read_backwards"
+license=('MIT')
+depends=("python")
+_name=${pkgname#python-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RobinNil/${_name//-/_}/archive/v$pkgver.tar.gz")
+md5sums=('38ee664ca2083ecf59fd09f4211c5406')
+
+build() {
+ cd ${_name//-/_}-$pkgver
+ export PYTHONSEED=1
+ python setup.py build
+}
+
+package() {
+ cd ${_name//-/_}-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}