summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..278ed4b29eb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-filesplitter
+ pkgdesc = File splitter is a tool that split large file into multiple small file
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/asrmarco13/the-file-splitter
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/F/FileSplitter/FileSplitter-2.0.tar.gz
+ md5sums = 1ab81f811823c8f85a3cecdd94ebd22f
+
+pkgname = python-filesplitter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecdccbda7061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: David Barchiesi <david@barchie.si>
+
+pkgname=python-filesplitter
+pkgver=2.0
+pkgrel=1
+pkgdesc="File splitter is a tool that split large file into multiple small file"
+arch=('any')
+url="https://github.com/asrmarco13/the-file-splitter"
+license=('GPLv3')
+makedepends=('python-setuptools')
+_name="FileSplitter"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+md5sums=('1ab81f811823c8f85a3cecdd94ebd22f')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}