summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 29 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49ae9c590a63..c3d610c46022 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Mar 26 13:48:02 UTC 2016
pkgbase = python-filterpy
- pkgdesc = Kalman filtering and optimal estimation library in Python.
- pkgver = 0.1.2
+ pkgdesc = Kalman filtering and optimal estimation library
+ pkgver = 1.4.5
pkgrel = 2
url = https://github.com/rlabbe/filterpy
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- makedepends = python-numpy
- makedepends = python-scipy
- makedepends = python-matplotlib
- source = https://github.com/rlabbe/filterpy/archive/0.1.2.tar.gz
- sha256sums = 42542b8a3e1792b4393ba0288cea2158ee922d029103b6cf8d52f3d11103554d
+ makedepends = python-wheel
+ depends = python-scipy
+ depends = python-matplotlib
+ source = filterpy-1.4.5.tar.gz::https://github.com/rlabbe/filterpy/archive/1.4.5.tar.gz
+ sha512sums = 22bc58142249f32d58aa7395342f455ef97469cf26635c5551634a5e4987ad7ef559ead38a3ebacfa447927c96f6ded5d08d2273ec8e86a26288c851ca6a63e5
pkgname = python-filterpy
-
diff --git a/PKGBUILD b/PKGBUILD
index 85400a1da833..2b5761520a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: tuftedocelot <tuftedocelot@fastmail.fm>
-
-pkgname=python-filterpy
-pkgver=0.1.2
+_base=filterpy
+pkgname=python-${_base}
+pkgver=1.4.5
pkgrel=2
-pkgdesc='Kalman filtering and optimal estimation library in Python.'
-arch=('any')
-url='https://github.com/rlabbe/filterpy'
-license=('MIT')
-makedepends=('python-setuptools' 'python-numpy' 'python-scipy' 'python-matplotlib')
-source=("https://github.com/rlabbe/filterpy/archive/$pkgver.tar.gz")
-sha256sums=('42542b8a3e1792b4393ba0288cea2158ee922d029103b6cf8d52f3d11103554d')
+pkgdesc="Kalman filtering and optimal estimation library"
+arch=(any)
+url="https://github.com/rlabbe/${_base}"
+license=(MIT)
+depends=(python-scipy python-matplotlib)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('22bc58142249f32d58aa7395342f455ef97469cf26635c5551634a5e4987ad7ef559ead38a3ebacfa447927c96f6ded5d08d2273ec8e86a26288c851ca6a63e5')
-package() {
- cd "$srcdir"/filterpy-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+build() {
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}