summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ff4dc6ef42..b339cdf71695 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,13 @@ pkgbase = python-fitsio-git
pkgdesc = A python library to read from and write to FITS files.
pkgver = r639.844055b
pkgrel = 1
- url = https://github.com/esheldon/fitsio
- arch = any
+ url = https://github.com/esheldon/fitsio.git
+ arch = x86_64
license = BSD
makedepends = git
depends = python
depends = python-numpy
- source = python-fitsio-git-r639.844055b::git+https://github.com/esheldon/fitsio
+ source = python-fitsio-git-r639.844055b::git+https://github.com/esheldon/fitsio.git
md5sums = SKIP
pkgname = python-fitsio-git
diff --git a/PKGBUILD b/PKGBUILD
index e6809678b63e..69133e182ac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ pkgrel=1
pkgdesc=" A python library to read from and write to FITS files. "
-arch=('any')
-url="https://github.com/esheldon/fitsio"
+arch=('x86_64')
+url="https://github.com/esheldon/fitsio.git"
license=('BSD')
groups=()
depends=('python' 'python-numpy')
@@ -50,6 +50,7 @@ pkgver() {
package() {
cd "$src"
cd "$pkgname-$pkgver"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python setup.py install --root=${pkgdir}
+ install -Dm644 gpl.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}