summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b28edfbef5..a2e4fcc512e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-flake8-blind-except
pkgdesc = A flake8 extension that checks for blind except: statements
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 0.2.1
+ pkgrel = 1
url = https://github.com/elijahandrews/flake8-blind-except
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-setuptools
- source = https://github.com/elijahandrews/flake8-blind-except/archive/v0.2.0/python-flake8-blind-except-0.2.0.tar.gz
- sha512sums = e96ca3e9cf6fa0d5f155f2136bfc150c6726591184d84f48b77385fda32727f4fa780563a7dc404bd8b0329fc2200f6ac796c5e644565155e51f4140e1eba0cd
+ depends = python
+ source = https://github.com/elijahandrews/flake8-blind-except/archive/v0.2.1/flake8-blind-except-0.2.1.tar.gz
+ sha512sums = 1786cf2709b94844d5eec91a81e9f3854f548e0a980cc3b869e5cd919d29ddce6ceba2d64a76b4a0b9524bc28cabf6851f0d33430eb65668b7f4a16bcd089332
pkgname = python-flake8-blind-except
diff --git a/PKGBUILD b/PKGBUILD
index fa3695b2031e..5c683405d828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
-pkgname=python-flake8-blind-except
-pkgver=0.2.0
-pkgrel=2
-pkgdesc='A flake8 extension that checks for blind except: statements'
-arch=('any')
-license=('MIT')
-url='https://github.com/elijahandrews/flake8-blind-except'
-depends=('python-setuptools')
-makedepends=('python-setuptools')
-source=("https://github.com/elijahandrews/flake8-blind-except/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('e96ca3e9cf6fa0d5f155f2136bfc150c6726591184d84f48b77385fda32727f4fa780563a7dc404bd8b0329fc2200f6ac796c5e644565155e51f4140e1eba0cd')
+_base=flake8-blind-except
+pkgname=python-${_base}
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A flake8 extension that checks for blind except: statements"
+arch=(any)
+license=(MIT)
+url="https://github.com/elijahandrews/${_base}"
+depends=(python)
+makedepends=(python-setuptools)
+source=(${url}/archive/v${pkgver}/${_base}-${pkgver}.tar.gz)
+sha512sums=('1786cf2709b94844d5eec91a81e9f3854f548e0a980cc3b869e5cd919d29ddce6ceba2d64a76b4a0b9524bc28cabf6851f0d33430eb65668b7f4a16bcd089332')
build() {
- cd flake8-blind-except-$pkgver
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
python setup.py build
}
package() {
- cd flake8-blind-except-$pkgver
- python setup.py install --root="$pkgdir"/ --optimize=1
- install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}