summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD29
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a9fbd08cd14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-flakeheaven
+ pkgdesc = Flake8 wrapper to make it nice, legacy-friendly, configurable. Flakehell fork.
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://flakeheaven.readthedocs.io/
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python
+ depends = python-attrs
+ depends = python-entrypoints
+ depends = python-typing-extensions
+ depends = python-termcolor
+ depends = python-flake8-quotes
+ depends = python-pygments
+ depends = python-isort
+ depends = python-pylint
+ depends = python-urllib3
+ depends = flake8
+ depends = python-mccabe
+ depends = python-flake8-commas
+ depends = python-flit-core
+ source = https://github.com/flakeheaven/flakeheaven/archive/refs/tags/0.11.0.tar.gz
+ sha512sums = 0ed08faf8db82f76874000c383fed0743d28383c31df9dc74a80b4b997c3ae87458c147de9538ce84f3ac238230acd67ac0d3c9a5730855c7dd752c72c7f056f
+
+pkgname = python-flakeheaven
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59d747959bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: brodokk <brodokk at brodokk dot space>
+
+_pkgname=flakeheaven
+pkgname=python-$_pkgname
+
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Flake8 wrapper to make it nice, legacy-friendly, configurable. Flakehell fork."
+
+url='https://flakeheaven.readthedocs.io/'
+arch=('any')
+license=('MIT')
+
+depends=('python' 'python-attrs' 'python-entrypoints' 'python-typing-extensions' 'python-termcolor' 'python-flake8-quotes' 'python-pygments' 'python-isort' 'python-pylint' 'python-urllib3' 'flake8' 'python-mccabe' 'python-flake8-commas' 'python-flit-core')
+makedepends=(python-build python-installer)
+
+source=("https://github.com/flakeheaven/$_pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('0ed08faf8db82f76874000c383fed0743d28383c31df9dc74a80b4b997c3ae87458c147de9538ce84f3ac238230acd67ac0d3c9a5730855c7dd752c72c7f056f')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+